Bug 1013822 - Empathy Audio Call Option Disabled
Empathy Audio Call Option Disabled
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 16:43 EDT by Zdenek Chmelar
Modified: 2015-02-21 07:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 06:31:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gnome contact (64.79 KB, image/png)
2013-09-30 16:43 EDT, Zdenek Chmelar
no flags Details
No possibility to call (39.78 KB, image/png)
2013-09-30 16:44 EDT, Zdenek Chmelar
no flags Details

  None (edit)
Description Zdenek Chmelar 2013-09-30 16:43:43 EDT
Created attachment 805528 [details]
Gnome contact

Description of problem:
I cannot initiate call from Empathy to google account (android user/android phone). The menu 'Audio Call' is greyed out.

Version-Release number of selected component (if applicable):
empathy-3.8.4-1.fc19.x86_64
telepathy-farstream-0.6.0-2.fc19.x86_64


How reproducible:
always

Steps to Reproduce:
1. Add (or use existing) gnome contact(s).
2. Open Empathy
3. Right click on gnome contact
4. 'Audio Call' is disabled.

Actual results:
I cannot make a call with GoogleTalk contact. I installed all possible gstreamer1-plugins as well as gstreamer-plugins but no success

Expected results:
'Audio Call' should be enabled and allow me to call GoogleTalk contact.

Additional info:
Please see attached screenshots with actual problem
Comment 1 Zdenek Chmelar 2013-09-30 16:44:33 EDT
Created attachment 805533 [details]
No possibility to call
Comment 2 Brian Pepple 2013-09-30 21:34:11 EDT
Does the person you are trying to call chat client advertise that the allow audio calls? (Based on your screenshot, I would say she doesn't). I tested this on my system, and the folks who are using a client that allows audio call have the 'audio call' option available.

Try using the Gnome context menu's 'New Call...' option, and it should open a dialog window with a list of folks from your contact list that allow audio calls.
Comment 3 Zdenek Chmelar 2013-10-01 15:26:44 EDT
First of all, thanks a lot for such a prompt feedback!

The attempt was to establish call between two gmail accounts (the one of mine under Empathy and her on Android phone).
I do not have further accounts in Empathy where I could test the calls. I just added first (her) gmail account in Empathy yesterday to test its call possibilities.
The screenshots were just from my Empathy showing we both have gmail account and the inactive 'Audio Call' dialog.

Her gmail uses 'hangouts' application and it looks like new google tool used for chat and video calls (on both gmail as well as android devices).
Chat works pretty well between her web-gmail/android and my Empathy in both directions.

Regarding calls, I did following tests:

1) I logged in on gmail with her account in Firefox (on my laptop). I checked her gmail configuration but there was nothing disabled, all allowed.
2) Under her ID (still in web gmail), I tried to call my gmail account (active in Empathy). Hangouts tool (under her web gmail) was dialing my account from her contact list but I did not receive any notification about incoming call in Empathy or any other type of notification on the desktop.
3) I switched from hangouts to old gmail chat client in her web-gmail. Again, calls from her account under Firefox didn't reach my gmail account in Empathy. Chat still works fine.
4) I cannot initiate call with her gmail ID from Empathy because of inactive 'Audio Call' menu.
5) I logged her off from gmail in Firefox and logged with my gmail account. I successfully called from my web gmail to her mobile phone.

Conclusion:

I'm able to establish calls from my gmail under Firefox to her android phone (e.g from web browser on laptop to her phone).
I'm not able to do the same with Empathy. I tried the same under Fedora 20 today but the same result (inactive 'Audio Call').

You wrote 'the folks who are using a client that allows audio call have the 'audio call' option available.' Are these people using gmail client as I do? If yes, then it seems to be only my problem probably.
Comment 4 Fedora End Of Life 2015-01-09 17:19:21 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2015-02-18 06:31:28 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 6 Frédéric Parrenin 2015-02-21 07:35:09 EST
I confirm this bug is still present under F21.

Note You need to log in before you can comment on or make changes to this bug.