Bug 1013838 - Request: Please drop dependancy on ModemManager
Request: Please drop dependancy on ModemManager
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-nm (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Grulich
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 17:46 EDT by Martin Kho
Modified: 2013-11-26 06:47 EST (History)
3 users (show)

See Also:
Fixed In Version: kde-plasma-nm-0.9.3.1-6.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 19:35:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2013-09-30 17:46:28 EDT
Description of problem:
With the introduction of kde-plasma-nm as replacement (?) for kde-plasma-networkmanagement in f20+ the dependancy on ModemManager is reintroduced. NetworkManager nor kde-plasma-networkmanagement requires ModemManager.

See also #809098

Version-Release number of selected component (if applicable):
kde-plasma-nm-0.9.3.0-6.fc19/fc20

How reproducible:
NA

Steps to Reproduce:
1. NA
2.
3.

Actual results:
ModemManager (and libmm-qt) are installed

Expected results:
ModemManager (and libmm-qt(?)) will no be installed

Additional info:
Comment 1 Fedora Update System 2013-10-01 06:19:08 EDT
kde-plasma-nm-0.9.3.0-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kde-plasma-nm-0.9.3.0-7.fc18
Comment 2 Fedora Update System 2013-10-01 06:20:03 EDT
kde-plasma-nm-0.9.3.0-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kde-plasma-nm-0.9.3.0-7.fc19
Comment 3 Fedora Update System 2013-10-01 06:25:32 EDT
kde-plasma-nm-0.9.3.0-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kde-plasma-nm-0.9.3.0-7.fc20
Comment 4 Martin Kho 2013-10-01 06:58:30 EDT
Hi Jan,

That was fast! Thanks. But may be it was a little too fast? This is what I get:

Downloaded:
kde-plasma-nm-0.9.3.0-7.fc19.x86_64.rpm
kde-plasma-nm-openconnect-0.9.3.0-7.fc19.x86_64.rpm
kde-plasma-nm-openvpn-0.9.3.0-7.fc19.x86_64.rpm
kde-plasma-nm-pptp-0.9.3.0-7.fc19.x86_64.rpm
kde-plasma-nm-vpnc-0.9.3.0-7.fc19.x86_64.rpm

sudo yum install kde-plasma-nm*:
Examining kde-plasma-nm-0.9.3.0-7.fc19.x86_64.rpm: kde-plasma-nm-0.9.3.0-7.fc19.x86_64
Marking kde-plasma-nm-0.9.3.0-7.fc19.x86_64.rpm to be installed
Examining kde-plasma-nm-openconnect-0.9.3.0-7.fc19.x86_64.rpm: kde-plasma-nm-openconnect-0.9.3.0-7.fc19.x86_64
Marking kde-plasma-nm-openconnect-0.9.3.0-7.fc19.x86_64.rpm to be installed
Examining kde-plasma-nm-openvpn-0.9.3.0-7.fc19.x86_64.rpm: kde-plasma-nm-openvpn-0.9.3.0-7.fc19.x86_64
Marking kde-plasma-nm-openvpn-0.9.3.0-7.fc19.x86_64.rpm to be installed             
Examining kde-plasma-nm-pptp-0.9.3.0-7.fc19.x86_64.rpm: kde-plasma-nm-pptp-0.9.3.0-7.fc19.x86_64
Marking kde-plasma-nm-pptp-0.9.3.0-7.fc19.x86_64.rpm to be installed         
Examining kde-plasma-nm-vpnc-0.9.3.0-7.fc19.x86_64.rpm: kde-plasma-nm-vpnc-0.9.3.0-7.fc19.x86_64
Marking kde-plasma-nm-vpnc-0.9.3.0-7.fc19.x86_64.rpm to be installed

Resolving
Dependencies
--> Running transaction check
---> Package kde-plasma-nm.x86_64 0:0.9.3.0-7.fc19 will be installed         
--> Processing Dependency: libmm-qt >= 0.5.0 for package: kde-plasma-nm-0.9.3.0-7.fc19.x86_64

[snip]

--> Processing Dependency: libnm-qt >= 0.9.0 for package: kde-plasma-nm-0.9.3.0-7.fc19.x86_64
--> Processing Dependency: libModemManagerQt.so.0()(64bit) for package: kde-plasma-nm-0.9.3.0-7.fc19.x86_64
--> Processing Dependency: libNetworkManagerQt.so.0()(64bit) for package: kde-plasma-nm-0.9.3.0-7.fc19.x86_64
---> Package kde-plasma-nm-openconnect.x86_64 0:0.9.3.0-7.fc19 will be installed
---> Package kde-plasma-nm-openvpn.x86_64 0:0.9.3.0-7.fc19 will be installed
---> Package kde-plasma-nm-pptp.x86_64 0:0.9.3.0-7.fc19 will be installed
---> Package kde-plasma-nm-vpnc.x86_64 0:0.9.3.0-7.fc19 will be installed
--> Running transaction check
---> Package libmm-qt.x86_64 1:0.5.1-1.fc19 will be installed
--> Processing Dependency: ModemManager >= 0.6.0 for package: 1:libmm-qt-0.5.1-1.fc19.x86_64                                                          ---> Package libnm-qt.x86_64 1:0.9.0-1.fc19 will be installed
--> Running transaction check
---> Package ModemManager.x86_64 0:0.6.2.0-1.fc19 will be installed
--> Finished Dependency Resolution

So the dependency seems to be still there...

Martin Kho
Comment 5 Jan Grulich 2013-10-01 07:24:28 EDT
Hmm, it will be more difficult as I thought, because libmm-qt requires ModemManager as well and it doesn't make sense to install libmm-qt without ModemManager. Maybe Rex Deiter will have some idea.
Comment 6 Jan Grulich 2013-10-01 11:34:42 EDT
It looks it's not possible at least there is no simple solution for removing ModemManager as dependency. We discussed it with rdieter and there are no benefits from this change except saving ~1Mb of space.
Comment 7 Fedora Update System 2013-10-23 05:15:18 EDT
kde-plasma-nm-0.9.3.1-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kde-plasma-nm-0.9.3.1-5.fc20
Comment 8 Fedora Update System 2013-10-23 13:31:13 EDT
Package kde-plasma-nm-0.9.3.1-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-nm-0.9.3.1-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19756/kde-plasma-nm-0.9.3.1-5.fc20
then log in and leave karma (feedback).
Comment 9 Martin Kho 2013-10-24 15:46:34 EDT
Hi,

I can disable ModemManager without a problem, but can't remove it. This seems fine to me. So I think this issue is solved.

Thanks,

Martin Kho
Comment 10 Fedora Update System 2013-11-06 21:18:25 EST
kde-plasma-nm-0.9.3.1-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kde-plasma-nm-0.9.3.1-6.fc20
Comment 11 Fedora Update System 2013-11-11 19:35:05 EST
kde-plasma-nm-0.9.3.1-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-11-22 06:15:28 EST
kde-plasma-nm-0.9.3.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kde-plasma-nm-0.9.3.2-1.fc18
Comment 13 Fedora Update System 2013-11-22 06:16:26 EST
kde-plasma-nm-0.9.3.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kde-plasma-nm-0.9.3.2-1.fc19
Comment 14 Martin Kho 2013-11-26 06:47:46 EST
Hi,

There is just one little annoyance when disabeling ModemManager. The logging get spammed with the following dbus messages:

Nov 26 12:41:27 localhost.localdomain dbus[338]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
Nov 26 12:41:27 localhost.localdomain dbus[338]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManager1.service failed to load: No such file or directory.

Note You need to log in before you can comment on or make changes to this bug.