Bug 1013939 - Default database configuration uses absolute paths
Default database configuration uses absolute paths
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity medium
: ER7
: 6.0.0
Assigned To: Thomas Hauser
Jiri Pechanec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 01:34 EDT by Jiri Pechanec
Modified: 2014-02-06 10:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Pechanec 2013-10-01 01:34:51 EDT
When installing ER4 from install then a user can configure a datasource to be used by some of the components. The problem is that the default value that relates to h2 used absolute paths for directory locations where the data files will be stored. Those paths point to 'data' dir in the server. So when the directory where server is located is renamed, then the paths are no longer valid.

The configuration should use jboss.server.data.dir by default to point to data dir instead of the absolute path.
Comment 1 Thomas Hauser 2013-10-16 11:15:38 EDT
Fixed for ER6 or later builds.
Comment 2 Jiri Pechanec 2013-12-13 00:39:59 EST
Verified in ER7

Note You need to log in before you can comment on or make changes to this bug.