Bug 1013948 - Even for engines which do already check IBus.InputPurpose.PASSWORD, sometimes the engine is enabled in the password entry field of the lock screen of gnome3
Even for engines which do already check IBus.InputPurpose.PASSWORD, sometimes...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 02:17 EDT by Mike FABIAN
Modified: 2013-11-25 23:13 EST (History)
4 users (show)

See Also:
Fixed In Version: ibus-1.5.4-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:42:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
input-engine-enabled-in-password-entry-field.ogv (310.25 KB, application/octet-stream)
2013-10-01 02:25 EDT, Mike FABIAN
no flags Details
Patch for bus/engineproxy.c (622 bytes, patch)
2013-10-01 03:43 EDT, fujiwara
no flags Details | Diff

  None (edit)
Description Mike FABIAN 2013-10-01 02:17:19 EDT
- Install Fedora 20 Alpha
- sudo yum install ibus-anthy
- sudo yum update --enablerepo=updates-testing ibus-typing-booster

Package version should now be >= this:

    ibus-1.5.4-1.fc20.x86_64
    ibus-anthy-1.5.4-1.fc20.x86_64
    ibus-typing-booster-1.2.4-1.fc20.noarch

- Add anthy input method using “gnome-control-center region”
- Select anthy input method in the gnome panel
- click on lock icon in the gnome panel to lock the screen
- type “aa”

→ One sees:

  [●あ      ]

  in the password entry field.

  I.e. while typing the first “a”, the anthy input method was
  disabled and an “a” was inserted and displayed as a bullet, while
  typing the second “a” anthy was enabled and one sees the あin the
  preëdit.
Comment 1 Mike FABIAN 2013-10-01 02:18:34 EDT
When using the mouse in the lock screen to push up the clock
and then typing the password, the problem does not occur.
To reproduce the problem, one needs to start typing immediately
an not push up the clock using the mouse.
Comment 2 Mike FABIAN 2013-10-01 02:25:19 EDT
Created attachment 805747 [details]
input-engine-enabled-in-password-entry-field.ogv

Video showing the problem.
Comment 3 Mike FABIAN 2013-10-01 02:26:38 EDT
ibus-typing-booster >= 1.2.4-1 shows the same problem as ibus-anthy.
Comment 4 fujiwara 2013-10-01 03:36:58 EDT
Workaround: Use mouse or Type Enter key before type the password char keys.
Comment 5 fujiwara 2013-10-01 03:43:41 EDT
Created attachment 805753 [details]
Patch for bus/engineproxy.c

Thank you for the report.

Actually I have tried f19 without the Fedora internal patch and I haven't noticed this problem in f20.
So I'm not sure if the problem is new or regression in f20 GDBusProxy cache.
It seems the cache is not saved immediatelly and the old cache is aways returned in this bug.
To fix this, need to save the cache by manual.
Attached the candidate patch.
Comment 7 Fedora Update System 2013-10-04 04:57:42 EDT
ibus-1.5.4-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-1.5.4-2.fc19
Comment 8 Fedora Update System 2013-10-04 04:58:20 EDT
ibus-1.5.4-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-1.5.4-2.fc18
Comment 9 Fedora Update System 2013-10-04 04:58:55 EDT
ibus-1.5.4-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-1.5.4-2.fc20
Comment 10 Fedora Update System 2013-10-04 21:40:59 EDT
Package ibus-1.5.4-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.5.4-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18298/ibus-1.5.4-2.fc20
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-11-10 01:42:55 EST
ibus-1.5.4-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-11-25 23:05:43 EST
ibus-1.5.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-11-25 23:13:57 EST
ibus-1.5.4-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.