Bug 1013991 - REST API should return correct status for SPM
REST API should return correct status for SPM
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.3.0
Unspecified Linux
high Severity unspecified
: ---
: 3.4.0
Assigned To: Maor
Elena
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 04:24 EDT by Kiril Nesenko
Modified: 2016-02-10 13:09 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-25 04:34:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Allon Mureinik 2013-10-02 05:20:04 EDT
Kiril, can you explain what this test is trying to do?
It's more likely that there is no SPM, not that it's reported incorrectly. Why does this test expect an SPM to be availble?
Comment 3 Kiril Nesenko 2013-10-02 06:17:14 EDT
(In reply to Allon Mureinik from comment #2)
> Kiril, can you explain what this test is trying to do?
> It's more likely that there is no SPM, not that it's reported incorrectly.
> Why does this test expect an SPM to be availble?

Test activates the DC with 3 hosts in it and then it checks if there is SPM host in that DC. And somehow the value for SPM is false.
Comment 4 Maor 2013-10-14 05:11:39 EDT
After discussing with Meital, it appears that this test has been failing with no consistency for over a year also at 3.2
It could be a race issue in the test,
Therefore, removing the testBlocker flag for now and will try to investigate it more.
Comment 5 Maor 2013-12-25 04:34:09 EST
I have tried to reproduce it on my environment and it did not reproduced.
Also looking at the recent tests it seems that this test passed successfully.
Also this test is no longer a CI test, and moved to QE.
As I wrote, in comment 4, this could be a race issue in the test.

After I have talked with Eyal Edri, and explained the reasons above, investigating it could be a waste of time.

based on the reasons above I'm closing it for now.
Please feel free to reopen when there is a consistent reproduce.

Note You need to log in before you can comment on or make changes to this bug.