Bug 1014002 - geo-replication log message points to 2.0 Administration guide for geo-rep env setup instead of 2.1.
geo-replication log message points to 2.0 Administration guide for geo-rep en...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Amar Tumballi
M S Vishwanath Bhat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 04:58 EDT by Gowrishankar Rajaiyan
Modified: 2016-05-31 21:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.39rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:41:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2013-10-01 04:58:22 EDT
Description of problem: Log message points to 2.0 Administration guide for geo-rep env setup instead of 2.1.


Version-Release number of selected component (if applicable):
glusterfs-geo-replication-3.4.0.33rhs-1.el6rhs.x86_64

How reproducible: Always


Steps to Reproduce:
1.
2.
3.

Actual results:
[2013-10-01 14:21:45.229409] I [monitor(monitor):129:monitor] Monitor: ------------------------------------------------------------
[2013-10-01 14:21:45.229784] I [monitor(monitor):130:monitor] Monitor: starting gsyncd worker
[2013-10-01 14:21:45.322992] I [gsyncd(/rhs2/snapstore):503:main_i] <top>: syncing: gluster://localhost:snapstore -> ssh://root@10.70.34.68:gluster://localhost:snapstore
[2013-10-01 14:21:45.431459] E [syncdutils(/rhs2/snapstore):190:log_raise_exception] <top>: connection to peer is broken
[2013-10-01 14:21:45.431751] W [syncdutils(/rhs2/snapstore):194:log_raise_exception] <top>: !!!!!!!!!!!!!
[2013-10-01 14:21:45.431907] W [syncdutils(/rhs2/snapstore):195:log_raise_exception] <top>: !!! getting "No such file or directory" errors is most likely due to MISCONFIGURATION, please consult http://access.redhat.com/knowledge/docs/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/chap-User_Guide-Geo_Rep-Preparation-Settingup_Environment.html
[2013-10-01 14:21:45.432054] W [syncdutils(/rhs2/snapstore):198:log_raise_exception] <top>: !!!!!!!!!!!!!


Expected results: Doc URL should be
https://access.redhat.com/site/documentation/en-US/Red_Hat_Storage/2.1/html/Administration_Guide/chap-User_Guide-Geo_Rep-Preparation-Settingup_Environment.html 


Additional info:
Comment 2 Amar Tumballi 2013-11-02 04:50:57 EDT
https://code.engineering.redhat.com/gerrit/15076
Comment 4 M S Vishwanath Bhat 2013-11-13 14:32:05 EST
Now this pointer is fixed.


Tested in version: glusterfs-3.4.0.44rhs-1.el6rhs.x86_64



log file snippets

host:slave
[2013-11-14 00:58:48.345978] E [syncdutils(/rhs/bricks/brick0):190:log_raise_exception] <top>: connection to peer is broken
[2013-11-14 00:58:48.346450] W [syncdutils(/rhs/bricks/brick0):194:log_raise_exception] <top>: !!!!!!!!!!!!!
[2013-11-14 00:58:48.346575] W [syncdutils(/rhs/bricks/brick0):195:log_raise_exception] <top>: !!! getting "No such file or directory" errors is most likely due to MISCONFIGURATION, please consult https://access.redhat.com/site/documentation/en-US/Red_Hat_Storage/2.1/html/Administration_Guide/chap-User_Guide-Geo_Rep-Preparation-Settingup_Environment.html
[2013-11-14 00:58:48.346668] W [syncdutils(/rhs/bricks/brick0):198:log_raise_exception] <top>: !!!!!!!!!!!!!
[2013-11-14 00:58:48.346843] E [resource(/rhs/bricks/brick0):204:errlog] Popen: command "ssh -oPasswordAuthentication=no -oStrictHostKeyChecking=no -i /var/lib/glusterd/geo-replication/secret.pem -oControlMaster=auto -S /tmp/gsyncd-aux-ssh-L2Ho1x/gsycnd-ssh-%r@%h:%p root@falcon /nonexistent/gsyncd --session-owner daa8799d-72c7-4d95-ba6f-040a29944e54 -N --listen --timeout 120 gluster://localhost:slave" returned with 127, saying:
[2013-11-14 00:58:48.346982] E [resource(/rhs/bricks/brick0):207:logerr] Popen: ssh> Warning: Identity file /var/lib/glusterd/geo-replication/secret.pem not accessible: No such file or directory.
[2013-11-14 00:58:48.347098] E [resource(/rhs/bricks/brick0):207:logerr] Popen: ssh> bash: /nonexistent/gsyncd: No such file or directory
[2013-11-14 00:58:48.347318] I [syncdutils(/rhs/bricks/brick0):159:finalize] <top>: exiting.
[2013-11-14 00:58:48.348640] I [monitor(monitor):81:set_state] Monitor: new state: faulty
[2013-11-14 00:58:58.428476] I [monitor(monitor):129:monitor] Monitor: ------------------------------------------------------------
[2013-11-14 00:58:58.428735] I [monitor(monitor):130:monitor] Monitor: starting gsyncd worker
[2013-11-14 00:58:58.563448] I [gsyncd(/rhs/bricks/brick0):530:main_i] <top>: syncing: gluster://localhost:master -> ssh://root@falcon:gluster://localhost:slave
[2013-11-14 00:58:58.642944] E [syncdutils(/rhs/bricks/brick0):190:log_raise_exception] <top>: connection to peer is broken
[2013-11-14 00:58:58.643127] W [syncdutils(/rhs/bricks/brick0):194:log_raise_exception] <top>: !!!!!!!!!!!!!
[2013-11-14 00:58:58.643232] W [syncdutils(/rhs/bricks/brick0):195:log_raise_exception] <top>: !!! getting "No such file or directory" errors is most likely due to MISCONFIGURATION, please consult https://access.redhat.com/site/documentation/en-US/Red_Hat_Storage/2.1/html/Administration_Guide/chap-User_Guide-Geo_Rep-Preparation-Settingup_Environment.html
[2013-11-14 00:58:58.643327] W [syncdutils(/rhs/bricks/brick0):198:log_raise_exception] <top>: !!!!!!!!!!!!!
[2013-11-14 00:58:58.643609] E [resource(/rhs/bricks/brick0):204:errlog] Popen: command "ssh -oPasswordAuthentication=no -oStrictHostKeyChecking=no -i /var/lib/glusterd/geo-replication/secret.pem -oControlMaster=auto -S /tmp/gsyncd-aux-ssh-7Tx3CE/gsycnd-ssh-%r@%h:%p root@falcon /nonexistent/gsyncd --session-owner daa8799d-72c7-4d95-ba6f-040a29944e54 -N --listen --timeout 120 gluster://localhost:slave" returned with 127, saying:
[2013-11-14 00:58:58.643742] E [resource(/rhs/bricks/brick0):207:logerr] Popen: ssh> Warning: Identity file /var/lib/glusterd/geo-replication/secret.pem not accessible: No such file or directory.
[2013-11-14 00:58:58.643843] E [resource(/rhs/bricks/brick0):207:logerr] Popen: ssh> bash: /nonexistent/gsyncd: No such file or directory
[2013-11-14 00:58:58.644054] I [syncdutils(/rhs/bricks/brick0):159:finalize] <top>: exiting.
[2013-11-14 00:59:08.655376] I [monitor(monitor):129:monitor] Monitor: ------------------------------------------------------------
[2013-11-14 00:59:08.655754] I [monitor(monitor):130:monitor] Monitor: starting gsyncd worker



Moving to verified.
Comment 5 errata-xmlrpc 2013-11-27 10:41:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.