Bug 1014005 - Validation errors after importing S-RAMP quickstarts into JBDS
Validation errors after importing S-RAMP quickstarts into JBDS
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples, Tooling (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER7
: 6.0.0
Assigned To: Kurt T Stam
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 05:01 EDT by Stefan Bunciak
Modified: 2014-02-06 10:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:27:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SRAMP-250 Major Closed Validation errors in the S-RAMP demos 2014-01-28 09:02:48 EST

  None (edit)
Description Stefan Bunciak 2013-10-01 05:01:48 EDT
Description of problem:

* Problems: http://pastebin.test.redhat.com/167242

* Some of the quickstarts needs to manually activate the demo & _testDependencies profiles to be built in JBDS

Version-Release number of selected component (if applicable):
* 6.0.0.ER3

How reproducible:


Steps to Reproduce:
1. Install FSW 6.0.0.ER3
2. Install JBDS 7 + JBDSIS 
3. Import as existing maven projects folder quickstarts/sramp

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-10-01 13:50:00 EDT
Is this issue a duplicate of any of these?


Newly created, or existing imported (e.g., quickstart) SwitchYard projects have requirement for JavaSE-1.6 
   https://bugzilla.redhat.com/show_bug.cgi?id=958447
 
Need to make it very clear that users must disable "Honour all XML schema locations" in preferences, XML→XML Files→Validation after installation
   https://bugzilla.redhat.com/show_bug.cgi?id=1013034
 
Importing SwitchYard quickstarts into JBDS results in non-fatal WARNING regarding log4j.dtd
   https://bugzilla.redhat.com/show_bug.cgi?id=1013048
Comment 2 Stefan Bunciak 2013-10-02 05:25:42 EDT
No, this is not a duplicate issue of any of the issues you mentioned. This issue has its own specific symptoms (mainly xml validation problems in web.xml but I have the 'Honour all Xml schema locations' unchecked).
Comment 3 JBoss JIRA Server 2013-10-15 08:35:49 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira SRAMP-250 to Resolved
Comment 4 JBoss JIRA Server 2013-10-15 08:35:56 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira SRAMP-250 to Closed
Comment 5 Kurt T Stam 2013-10-15 08:37:47 EDT
fixed the errors in the s-ramp-demos-custom-deriver demo, the project demo has moved to dtgov.
Comment 6 Andrej Podhradsky 2013-11-18 07:37:46 EST
Unfortunately, pastebin at http://pastebin.test.redhat.com/167242 is empty :(

So, I add errors which I see.

After importing the quickstart 's-ramp-demos-switchyard-multiapp' there are the following errors:

Required Capability Missing: The "Bean" capability should be configured on the project when using this type of implementation.
Required Capability Missing: The "Bean" capability should be configured on the project when using this type of implementation.
Required Capability Missing: The "Camel Core (SEDA/Timer/URI)" capability should be configured on the project when using this type of binding.
Required Capability Missing: The "Camel Route" capability should be configured on the project when using this type of implementation.
Required Capability Missing: The "SOAP" capability should be configured on the project when using this type of binding.
Required Capability Missing: The "SOAP" capability should be configured on the project when using this type of binding.
Unresolvable Bean Class: "org.switchyard.quickstarts.demo.multiapp.service.InventoryServiceBean" cannot be resolved for "InventoryService".
Unresolvable Bean Class: "org.switchyard.quickstarts.demo.multiapp.service.OrderServiceBean" cannot be resolved for "OrderService".

Is this fixed or is it a new bug?
Comment 7 Andrej Podhradsky 2013-12-18 03:57:38 EST
Verified with FSW 6.0.0.ER7-2 and JBDS-IS 7.0.0.CR1. Note that there is still one bug with building the s-ramp demo, see https://bugzilla.redhat.com/show_bug.cgi?id=1041334

Note You need to log in before you can comment on or make changes to this bug.