Bug 1014010 - Libreoffice crashes at start - Segfault
Libreoffice crashes at start - Segfault
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Stephan Bergmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 05:12 EDT by linux4fun
Modified: 2013-10-09 10:21 EDT (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-4.1.2.3-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 04:18:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core dump (1.37 MB, application/x-zip)
2013-10-01 05:12 EDT, linux4fun
no flags Details

  None (edit)
Description linux4fun 2013-10-01 05:12:13 EDT
Created attachment 805777 [details]
Core dump

Description of problem: When I launch Libreoffice, the startup screen appears for a second and then goes away


Version-Release number of selected component (if applicable):
libreoffice-math-4.1.2.2-1.fc19.x86_64
libreoffice-base-4.1.2.2-1.fc19.x86_64
libreoffice-graphicfilter-4.1.2.2-1.fc19.x86_64
libreoffice-ure-4.1.2.2-1.fc19.x86_64
libreoffice-emailmerge-4.1.2.2-1.fc19.x86_64
libreoffice-4.1.2.2-1.fc19.x86_64
libreoffice-core-4.1.2.2-1.fc19.x86_64
libreoffice-pdfimport-4.1.2.2-1.fc19.x86_64
libreoffice-opensymbol-fonts-4.1.2.2-1.fc19.noarch
libreoffice-draw-4.1.2.2-1.fc19.x86_64
libreoffice-langpack-fr-4.1.2.2-1.fc19.x86_64
libreoffice-calc-4.1.2.2-1.fc19.x86_64
libreoffice-impress-4.1.2.2-1.fc19.x86_64
libreoffice-writer-4.1.2.2-1.fc19.x86_64
libreoffice-pyuno-4.1.2.2-1.fc19.x86_64
libreoffice-langpack-en-4.1.2.2-1.fc19.x86_64

How reproducible: Whenever I start Libreoffice


Steps to Reproduce:
1.Just start Libreoffice with this version and it won't start

Actual results: Nothing


Expected results: Libreoffice should start


Additional info: Apparently, the previous version I was using was 4.1.1.2-5 and it was working ok.
Comment 1 Stephan Bergmann 2013-10-01 05:51:04 EDT
The relevant backtrace from the attachment is

> #0  get () at /usr/src/debug/libreoffice-4.1.2.2/include/rtl/instance.hxx:601
> #1  cppu_detail_getUnoType () at /usr/src/debug/libreoffice-4.1.2.2/workdir/unxlngx6.pro/UnoApiHeadersTarget/udkapi/comprehensive/com/sun/star/registry/InvalidRegistryException.hpp:73
> #2  get () at /usr/src/debug/libreoffice-4.1.2.2/include/cppu/unotype.hxx:267
> #3  com::sun::star::registry::cppu_detail_getUnoType () at /usr/src/debug/libreoffice-4.1.2.2/workdir/unxlngx6.pro/UnoApiHeadersTarget/udkapi/comprehensive/com/sun/star/registry/XRegistryKey.hpp:214
> #4  0x0000003661e9bf3f in get () at /usr/src/debug/libreoffice-4.1.2.2/include/cppu/unotype.hxx:267
> #5  cppu_detail_getUnoType<com::sun::star::registry::XRegistryKey> () at /usr/src/debug/libreoffice-4.1.2.2/include/cppu/unotype.hxx:236
> #6  get () at /usr/src/debug/libreoffice-4.1.2.2/include/cppu/unotype.hxx:267
> #7  getCppuType () at /usr/src/debug/libreoffice-4.1.2.2/workdir/unxlngx6.pro/UnoApiHeadersTarget/udkapi/comprehensive/com/sun/star/registry/XRegistryKey.hpp:775
> #8  cppu::(anonymous namespace)::invokeComponentFactory (pGetter=0x7f5d4b16d6a0 <configmgr_component_getFactory(char const*, void*, void*)>, lib=lib@entry=0x176bb30, rModulePath="file:///usr/lib64/libreoffice/program/../program/libconfigmgrlo.so", rImplName="com.sun.star.comp.configuration.DefaultProvider", xMgr=..., xKey=..., rPrefix="configmgr_", rExcMsg="") at /usr/src/debug/libreoffice-4.1.2.2/cppuhelper/source/shlib.cxx:391
> #9  0x0000003661e9d617 in cppu::loadSharedLibComponentFactory (rLibName="file:///usr/lib64/libreoffice/program/../program/libconfigmgrlo.so", rPath="", rImplName="com.sun.star.comp.configuration.DefaultProvider", xMgr=..., xKey=..., rPrefix="configmgr_") at /usr/src/debug/libreoffice-4.1.2.2/cppuhelper/source/shlib.cxx:597
> #10 0x0000003661e8b15b in cppuhelper::ServiceManager::loadImplementation (this=this@entry=0x7f5d51b5a308, context=..., info=..., factory1=factory1@entry=0x7fffd5601ff0, factory2=factory2@entry=0x7fffd5602000) at /usr/src/debug/libreoffice-4.1.2.2/cppuhelper/source/servicemanager.cxx:655
> #11 0x0000003661e8c83c in cppuhelper::ServiceManager::findServiceImplementation (this=this@entry=0x7f5d51b5a308, context=..., specifier=...) at /usr/src/debug/libreoffice-4.1.2.2/cppuhelper/source/servicemanager.cxx:1667
> #12 0x0000003661e8c9b3 in cppuhelper::ServiceManager::createInstanceWithContext (this=0x7f5d51b5a308, aServiceSpecifier=..., Context=...) at /usr/src/debug/libreoffice-4.1.2.2/cppuhelper/source/servicemanager.cxx:791
> #13 0x0000003661e2e40c in cppu::ComponentContext::lookupMap (this=this@entry=0x7f5d51b4fe48, rName="/singletons/com.sun.star.configuration.theDefaultProvider") at /usr/src/debug/libreoffice-4.1.2.2/cppuhelper/source/component_context.cxx:590
> #14 0x0000003661e2e8aa in cppu::ComponentContext::getValueByName (this=0x7f5d51b4fe48, rName="/singletons/com.sun.star.configuration.theDefaultProvider") at /usr/src/debug/libreoffice-4.1.2.2/cppuhelper/source/component_context.cxx:656
> #15 0x000000366c634471 in com::sun::star::configuration::theDefaultProvider::get (the_context=...) at /usr/src/debug/libreoffice-4.1.2.2/workdir/unxlngx6.pro/UnoApiHeadersTarget/offapi/normal/com/sun/star/configuration/theDefaultProvider.hpp:24
> #16 0x000000366c642e86 in desktop::LanguageSelection::prepareLanguage () at /usr/src/debug/libreoffice-4.1.2.2/desktop/source/app/langselect.cxx:104
> #17 0x000000366c61305d in desktop::Desktop::Init (this=0x7fffd5602810) at /usr/src/debug/libreoffice-4.1.2.2/desktop/source/app/app.cxx:594
> #18 0x0000003668722e94 in InitVCL () at /usr/src/debug/libreoffice-4.1.2.2/vcl/source/app/svmain.cxx:283
> #19 0x0000003668723e28 in ImplSVMain () at /usr/src/debug/libreoffice-4.1.2.2/vcl/source/app/svmain.cxx:156
> #20 0x0000003668723ee2 in SVMain () at /usr/src/debug/libreoffice-4.1.2.2/vcl/source/app/svmain.cxx:198
> #21 0x000000366c64bb15 in soffice_main () at /usr/src/debug/libreoffice-4.1.2.2/desktop/source/app/sofficemain.cxx:82
> #22 0x000000000040071b in sal_main () at /usr/src/debug/libreoffice-4.1.2.2/desktop/source/app/main.c:48
> #23 main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/libreoffice-4.1.2.2/desktop/source/app/main.c:47

The problem appears to be that the isBootstrapType list in codemaker/source/cppumaker/cpputype.cxx inadvertently misses "com.sun.star.registry.InvalidRegistryException" as used by "com.sun.star.registry.XRegistryKey", so that it depends "on luck" whether a matching or non-matching instance of its (ODR-violating) implementation is picked up across the dynamic libraries already loaded.
Comment 2 Fedora Update System 2013-10-02 11:06:51 EDT
libreoffice-3.6.7.2-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libreoffice-3.6.7.2-4.fc18
Comment 3 Fedora Update System 2013-10-02 11:54:19 EDT
libreoffice-4.1.2.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libreoffice-4.1.2.3-2.fc19
Comment 4 Fedora Update System 2013-10-02 21:17:10 EDT
Package libreoffice-4.1.2.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.1.2.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18192/libreoffice-4.1.2.3-2.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-10-03 04:18:23 EDT
libreoffice-4.1.2.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.1.2.3-2.fc20
Comment 6 Fedora Update System 2013-10-03 21:56:15 EDT
libreoffice-4.1.2.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-10-03 22:05:25 EDT
Package libreoffice-4.1.2.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.1.2.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18293/libreoffice-4.1.2.3-2.fc20
then log in and leave karma (feedback).
Comment 8 linux4fun 2013-10-04 04:04:50 EDT
Hello,

Thank you for your help, I'm impressed by the short time it took to be fixed ;-)
I have just seen the fix is available in Fedora 19, so I updated with yum and it's working ok now.
I guess it can be closed as Fixed, but I don't seem to be able to do that.

Thank you
Comment 9 Stephan Bergmann 2013-10-04 04:18:29 EDT
(In reply to linux4fun from comment #8)
> I have just seen the fix is available in Fedora 19, so I updated with yum
> and it's working ok now.

Glad to hear it works for you.  (The fix was a bit of a shot in the dark, as I wasn't able to reproduce your problem and could only draw conclusions from the provided backtrace.)

> I guess it can be closed as Fixed, but I don't seem to be able to do that.

Looks like Fedora Update System fought itself with closing this issue.  I manually set it back to closed now.
Comment 10 Fedora Update System 2013-10-09 10:21:50 EDT
libreoffice-4.1.2.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.