Bug 1014016 - glance api hangs with low (1) workers on multiple parallel image creation requests
glance api hangs with low (1) workers on multiple parallel image creation req...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 4.0
Assigned To: Flavio Percoco
Yogev Rabl
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 05:28 EDT by Alan Pevec
Modified: 2016-04-26 15:07 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-glance-2013.2-3.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1008818
Environment:
Last Closed: 2013-12-19 19:25:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1229042 None None None Never
OpenStack gerrit 50258 None None None Never

  None (edit)
Description Alan Pevec 2013-10-01 05:28:55 EDT
+++ This bug was initially created as a clone of Bug #1008818 +++

Description of problem:
Glance api can hang in registry notification.

Version-Release number of selected component (if applicable):
RDO havana

How reproducible:
Usually

Steps to Reproduce:
1. openstack-config --set /etc/glance/glance-api.conf DEFAULT workers 1 
2. service openstack-glance-api restart
3. Try several times:
for ((a=0; a<16; a++)) do
        glance  image-create --name image-$a --container-format bare --disk-format raw --file /etc/passwd &
done

Actual results:
glance image-list # Times out
API service hangs for forever.

glance-api service restart is required to continue the normal operation.

Expected results:
Service does noh hangs.


Additional info:
- On F19-devstack havana, RHEL-RDO-havana with pyhon-qpid 0.14 .. 0.24
- Tested on a 2 Core VM
- With rabbitMq the response is 500, so the bug can be related to the glance-registry. 

- No issue seen with workers=2 yet.
- glnace image-create command without the --file argument also can cause hanging issues.
Comment 2 Scott Lewis 2013-11-19 11:54:23 EST
Auto adding >= MODIFIED bugs to beta
Comment 4 Yogev Rabl 2013-12-03 10:14:32 EST
verified on:

python-glanceclient-0.10.0-1.el6ost.noarch
python-glance-2013.2-3.el6ost.noarch
openstack-glance-2013.2-3.el6ost.noarch
Comment 7 errata-xmlrpc 2013-12-19 19:25:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.