Bug 101403 - coreutils-5.0-9 changes the su xauth
coreutils-5.0-9 changes the su xauth
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: coreutils (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-31 14:28 EDT by Sammy
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-06 08:36:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2003-07-31 14:28:40 EDT
Upgrading coreutils to 5.0-9 and restarting X stops the execution of and X11 
program from an su window (login to user account and su in a terminal). 
Going back to 5.0-6 and restarting X solves the problem. Is this an intended 
behavior? Everything else is todays rawhide level (7/31/03).
Comment 1 Tim Waugh 2003-08-01 05:54:25 EDT
Please be more specific about the behaviour you see.  Everything looks normal
here with coreutils-5.0-9.
Comment 2 Sammy 2003-08-01 10:25:45 EDT
I just tested it again. Steps: 
 
1. Insall coreutils-5.0-9 
2. Restart X server and login (KDE) as user (if we don't restart X server it works!) 
3. Do an su from konsole window 
4. Try to start any X applications e.g. xterm 
 
# xterm 
Xlib: connection to ":0.0" refused by server 
Xlib: No protocol specified 
 
5. Downgrade to -6, same line above works 
Comment 3 Tim Waugh 2003-08-01 11:41:48 EDT
Can't reproduce this.  It works for me.
Comment 4 Sammy 2003-08-06 12:23:03 EDT
I have investigated this and found out how to fix it: 
 
1. When I build coreutils-5.0-9 rpm from the exact source rpm I get the problem 
    mentioned above. 
 
2. When I comment out just the three lines: 
 
   #aclocal -I m4 
   #autoconf --force 
   #automake --copy --force 
 
   and rebuild the rpm (one also has to remove the last hunk of coreutils-4.5.3-hname.patch, 
   which fixes a dependecy for man page), 
 
   IT WORKS!! Tried it a number of times to make sure. 
 
Comment 5 Tim Waugh 2003-08-06 12:35:08 EDT
Then perhaps it's the ACL patch?  Those lines are necessary to make the
Makefile.am changes propagate through.

If you create a new user account, does the same problem happen for that user?
Comment 6 Sammy 2003-08-06 14:12:42 EDT
Well, this is confusing. I created a new user and it did not  happen BUT now I can't 
make it happen again by installing the coreutils package from rawhide for any user. 
Something got fixed in the process. 
Comment 7 Tim Waugh 2003-10-03 05:20:42 EDT
Do you still see this with coreutils-5.0-14?
Comment 8 Sammy 2003-10-06 08:31:35 EDT
No! 

Note You need to log in before you can comment on or make changes to this bug.