Bug 101407 - Glade2 projects made with the included glade2 makes python segfault.
Glade2 projects made with the included glade2 makes python segfault.
Status: CLOSED CANTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: pygtk2 (Show other bugs)
beta1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-31 14:46 EDT by Kent Nyberg
Modified: 2013-03-13 00:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 20:18:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the .glade file i use. (10.49 KB, text/plain)
2003-07-31 14:48 EDT, Kent Nyberg
no flags Details

  None (edit)
Description Kent Nyberg 2003-07-31 14:46:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/0.8.0

Description of problem:
The following script makes python crash on a glade2 project created with the
glade2 included in Beta1. I have also downloaded glade2 from rawhide  (31 July
2003) and it does not change anything so i guess it must be the python module
that is buggy.

Here is the script (It is also the same that could be found in 
"/usr/share/doc/pygtk2-1.99.16/examples/glade")

(The gnome2 project is the easiest one possible, i start glade and create a new
gnome2 project. Then saves the file and tries to open the .glade file. I have
not done some fancy UI.. just the standard one created when doing a glade2-gnome
project.)

[code start]


#!/usr/bin/env python
import sys
import gtk
import gtk.glade
 
if len(sys.argv) > 1:
    fname = sys.argv[1]
else:
    fname = 'test.glade'
 
# create widget tree ...
xml = gtk.glade.XML(fname)
 
def gtk_main_quit(*args):
    gtk.main_quit()
 
xml.signal_autoconnect(locals())
 
gtk.main()


[code end]



The error message i get is the following:

(glade-demo.py:4233): GLib-GObject-CRITICAL **: file gobject.c: line 1002
(g_object_get): assertion `G_IS_OBJECT (object)' failed
 
(glade-demo.py:4233): GLib-GObject-CRITICAL **: file gobject.c: line 1002
(g_object_get): assertion `G_IS_OBJECT (object)' failed
Segmenteringsfel


Version-Release number of selected component (if applicable):
pygtk*1.99.16-6

How reproducible:
Always

Steps to Reproduce:
1. Well, since it is a script i can run it and it always crash when i try to
load the .glade file.
2. It is always the same error-message.
3.
    

Actual Results:  The interface is not loaded, the script segfaults.

Expected Results:  It should show the interface.

Additional info:

I asked if some one had these problem on the mailinglist and sent the script. I
got a reply from one person saying it worked for him on a gnome2 .glade file. I
have sent my .glade file to him but have not yet got a reply if it workes or not.
Comment 1 Kent Nyberg 2003-07-31 14:48:45 EDT
Created attachment 93300 [details]
This is the .glade file i use.

Well, this is my .glade file. It should be a simple gnome2 project from glade.
Comment 2 Jon Willeke 2003-08-09 16:04:43 EDT
You need to call gnome.init() before loading a .glade file that requires GNOME.
 Also, your script will be more portable with the following statements:

  import pygtk
  pygtk.require( '2.0' )

SuSE Linux 8.2, for example, still defaults to PyGTK 0.6 for GTK+ 1.2.
Comment 3 Bill Nottingham 2006-08-07 11:53:09 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still running
Red Hat Linux, you are strongly advised to upgrade to a current Fedora Core
release or Red Hat Enterprise Linux or comparable. Some information on which
option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks. Please check if this
issue is still present in a current Fedora Core release. If so, please change
the product and version to match, and check the box indicating that the
requested information has been provided. Note that any bug still open against
Red Hat Linux by the end of 2006 will be closed as 'CANTFIX'. Thanks again for
your help.
Comment 5 Bill Nottingham 2007-07-26 20:18:10 EDT
Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.