Bug 1014114 - Wrong Java detected in sqlresults.log
Wrong Java detected in sqlresults.log
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity medium
: ER8
: 6.0.0
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 08:42 EDT by Stefan Bunciak
Modified: 2014-02-06 10:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Bunciak 2013-10-01 08:42:27 EDT
Description of problem:

Wrong Java detected in sqlresults.log:
Detected Java version: 1.5 in: /usr/java/jdk1.7.0_25/jre

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install FSW 6.0.0.ER4
2. Configure wrong DB connection so installer will fail to configure Database schema
3. Check jboss-eap-6.1/sql/sqlresults.log

Actual results:


Expected results:


Additional info:
Comment 1 Thomas Hauser 2013-10-01 15:23:27 EDT
This was resulting because the version of ant that the installer was getting included within it was very old (checks for versions beyond 1.5 didn't exist.) Updating the dependency to be correct yields

Detected Java version: 1.7 in: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64/jre

Within the same file after an installation. This can be in either the beta rebuild or in the next ER, depending on what we want to happen.
Comment 5 Stefan Bunciak 2013-10-08 04:08:26 EDT
I can still reproduce in latest ER4:

Detected Java version: 1.5 in: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.2.7.fc19.x86_64/jre
Comment 6 Stefan Bunciak 2014-01-06 04:24:12 EST
Verified in FSW 6.0.0.ER8

Note You need to log in before you can comment on or make changes to this bug.