This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1014130 - UI changes to JDBC Driver Setup screen
UI changes to JDBC Driver Setup screen
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER7
: 6.0.0
Assigned To: Thomas Hauser
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 08:59 EDT by Stefan Bunciak
Modified: 2014-02-06 10:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed changes (113.20 KB, image/png)
2013-10-01 11:50 EDT, Thomas Hauser
no flags Details
JDBC Driver UI proposal (QE) (103.62 KB, image/png)
2013-10-02 04:49 EDT, Stefan Bunciak
no flags Details
Showing Updated UI (85.61 KB, image/png)
2013-10-02 11:33 EDT, Miles Tjandrawidjaja
no flags Details

  None (edit)
Description Stefan Bunciak 2013-10-01 08:59:27 EDT
Description of problem:

On JBDS Driver Setup screen (post-installation):
* move 2 jar buttons (add, remove) below the driver jar locations (below the last jar) since the 'Remove jar' works for the last jar file
* change caption of the 'Add jar' button change to 'Add additional jar' since the first thing user does is that he clicks on 'Add jar' and then he realizes that this action added another (2nd, ..) jar file location field.

Version-Release number of selected component (if applicable):
* 6.0.0.ER3

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Stefan Bunciak 2013-10-01 09:01:35 EDT
Description should be: On JDBC Driver Setup screen (post-installation), sorry for typo.
Comment 2 Thomas Hauser 2013-10-01 11:50:29 EDT
Created attachment 806066 [details]
Proposed changes

Here's a snapshot of some changes I've made. Let me know if this is good enough / other changes that should be made from a UX perspective.
Comment 3 Stefan Bunciak 2013-10-02 04:48:39 EDT
(In reply to Thomas Hauser from comment #2)
> Created attachment 806066 [details]
> Proposed changes
> 
> Here's a snapshot of some changes I've made. Let me know if this is good
> enough / other changes that should be made from a UX perspective.


Much better! But we discussed that 2 additional changes could be made: 
* the 'Path' label could be removed
* the 1st file input should be aligned with the 'Driver JAR locations' label (to be in one line)

Attached QE proposal.
Comment 4 Stefan Bunciak 2013-10-02 04:49:13 EDT
Created attachment 806310 [details]
JDBC Driver UI proposal (QE)
Comment 5 Thomas Hauser 2013-10-02 09:46:49 EDT
Note that these changes are in IzPack and cannot be made available unless IzPack is rebuilt for this ER. Will look into implementing these changes after critical functionality bugs are repaired.
Comment 6 Miles Tjandrawidjaja 2013-10-02 11:33:19 EDT
Created attachment 806547 [details]
Showing Updated UI

Path label has been removed.
Driver JAR location label will always be aligned with first input file.

http://git.app.eng.bos.redhat.com/?p=jbossas-installer.git;a=commit;h=7f61b2bf98fc704ed5c0d7856a9d460b92141b82

http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=956f6618de9b9541db82fb69205742251f366483

One more commit was made afterwards when I realized I needed a space between the driver vendor and Driver Jar locations.
Comment 10 Pavol Srna 2013-12-16 05:09:20 EST
Verified in ER7.

Note You need to log in before you can comment on or make changes to this bug.