Bug 101414 - VNC installation still asks for mouse, plus has traceback messages
VNC installation still asks for mouse, plus has traceback messages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-31 16:16 EDT by david d zuhn
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 11:27:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description david d zuhn 2003-07-31 16:16:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I'm trying to do an install via VNC (very cool feature, BTW, one I expect to use
a lot).  I'm doing this on a headless machine with only a serial console & PXE
booting.  I've configured my PXE server with the kernel & initrd from the
images/pxeboot subdir, and have a kernel arguments of:

ip=dhcp initrd=/redhat/rhel/ia32/initrd.img  console=ttyS0,115200 vnc
vncpassword=<password>

When I boot, I get the usual prompts for language, and where to get the ISO
images from (NFS in this case).  Then anaconda starts, probes for video,
monitor, and mouse.  I have no mouse on this machine.  So I'm forced into a very
raw text screen to choose a mouse (much more raw than the text screens I've just
been using, e.g., to select my ISO image location).   It's VERY hard to tell
what my current selection is on this screen (no color changes, etc).   When I
select no mouse, I'm
prompted to either select a mouse or go into text mode.  I don't want
text mode, I want VNC mode.

When I finally broke down, and selected text mode, VNC mode started up.  Perhaps
the choices when I don't have a mouse could explicitly include VNC mode as well
as text mode.

On the serial console, I got the following messages as the VNC server was
starting up:Using mouse type: No - mouse
Starting VNC...
The VNC server now running.
Please connect to pipestone:1 to begin the install...
Traceback (most recent call last):
  File "/usr/bin/loadkeys", line 26, in ?
    main()
  File "/usr/bin/loadkeys", line 22, in main
    isys.loadKeymap(sys.argv[1])
  File "/usr/lib/anaconda/isys.py", line 229, in loadKeymap
    return _isys.loadKeymap (keymap)
SystemError: (-22, 'Unknown error 4294967274')
XKB extension not present on :1
Xlib:  extension "RENDER" missing on display ":1.0".
 
the XKB & RENDER messages I understand, but I don't think the traceback from
loadkeys is appropriate.  





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Headless system, no mouse
2. Network installation, using NFS and 'vnc' in the kernel arguments.
3. No Mouse is selected, I'm prompted to configure a mouse, or go
   into text mode.
4. Go into text mode, and I end up in VNC mode.

    

Expected Results:  I don't believe I should have been prompted so heavily to
configure a mouse.   I should have been offered VNC as a choice as well as text
mode, or at least given some indication that my vnc choice was going to be honored.


Additional info:
Comment 1 Jeremy Katz 2003-07-31 17:06:44 EDT
Fixed to not bug about mouse if you're doing vnc mode.  Also made loadkeys a
little bit smarter about not running unless on a real console.
Comment 2 david d zuhn 2003-08-05 10:46:42 EDT
Just noting that the same things occured when doing a similar install using
severn.  I hope that anaconda is common to both release lines, so that the
comment above about a fix applies to severn as well.
Comment 3 david d zuhn 2003-09-17 11:52:14 EDT
I just did this install on RHEL beta2, and while I had no problems about the
mouse, I did still get a traceback on the loadkeys operation:

The VNC server now running.
Please connect to pipestone:1 to begin the install...
Traceback (most recent call last):
  File "/usr/bin/loadkeys", line 26, in ?
    main()
  File "/usr/bin/loadkeys", line 22, in main
    isys.loadKeymap(sys.argv[1])
  File "/usr/lib/anaconda/isys.py", line 229, in loadKeymap
    return _isys.loadKeymap (keymap)
SystemError: (-22, 'Unknown error 4294967274')
Comment 4 david d zuhn 2004-02-13 10:48:27 EST
This bug also occurs on FC2-test1.  Should I open a new bug against
that release?   
Comment 5 Jeremy Katz 2004-02-13 13:26:46 EST
We have to ask for a mouse to set up the mouse for the post-install
system (just because you're installing via vnc doesn't mean that
you're not going to be using normal X post-install).  And I just fixed
the (cosmetic) traceback yesterday.
Comment 6 Bill Nottingham 2004-10-11 11:27:43 EDT
Closing MODIFIED bugs as fixed. Please reopen if the problem perists.

Note You need to log in before you can comment on or make changes to this bug.