Bug 101415 - smartd startup fails on s390 after install (no /dev/hda)
Summary: smartd startup fails on s390 after install (no /dev/hda)
Status: CLOSED DUPLICATE of bug 99156
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils   
(Show other bugs)
Version: 3.0
Hardware: s390 Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-31 20:19 UTC by Daniel Jarboe
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Jarboe 2003-07-31 20:19:53 UTC
Description of problem:
After taroon-beta1 install, smartd is started by default in runlevels 3 and 5, 
with a default /etc/smartd.conf of "/dev/hda -H -m root@localhost.localdomain", 
which is inappropriate for s390.

Version-Release number of selected component (if applicable):
kernel-utils-2.4-8.32

How reproducible:
Always

Steps to Reproduce:
1. Install taroon-beta1 on s390
2. IPL
    

Actual Results:  smartd dead but subsys locked

Expected Results:  More sensible default config for s390?

Additional info:

in /var/log/messages:
smartd[699]: smartd version 5.1-11 Copyright (C) 2002-3 Bruce Allen
smartd[699]: Home page is http://smartmontools.sourceforge.net/
smartd[699]: Using configuration file /etc/smartd.conf
smartd[699]: Device: /dev/hda, No such file or directory, open() failed
smartd[699]: Unable to register ATA device /dev/hda at line 30 of 
file /etc/smartd.conf
smartd[699]: Unable to register device /dev/hda - exiting.
smartd: smartd startup failed

Comment 1 Bill Nottingham 2003-07-31 20:32:07 UTC

*** This bug has been marked as a duplicate of 99156 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:57:54 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.