Bug 1014157 - kie-ci does not resolve properties that are used for artifact version
kie-ci does not resolve properties that are used for artifact version
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER5
: 6.0.0
Assigned To: Mario Fusco
Tomas David
:
: 1008538 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 09:18 EDT by Maciej Swiderski
Modified: 2014-08-06 16:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:17:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DROOLS-266 Major Resolved KIE resolving dependend artifacts issue 2014-01-16 09:52:28 EST

  None (edit)
Description Maciej Swiderski 2013-10-01 09:18:33 EDT
Description of problem:
When kjar has dependencies declared with their versions defined as property instead of having them placed as <version> tag directly on dependency then creation of kieContainer fails with NPE

Version-Release number of selected component (if applicable):


How reproducible:
see reproducer

Steps to Reproduce:
1.
2.
3.

Actual results:
NPE thrown when creating KieContainer

Expected results:
KieContainer is created successfully with all dependencies resolved properly

Additional info:
Might be worth investigating if various scope dependencies shall be resolved as well, mainly test and provided as in my opinion test dependencies should not be resolved at all and provided might be but I would say that when marking dependency as provided it is expected to already be on the main class loader and should not be project specific classloader.
Comment 2 Maciej Swiderski 2013-10-01 09:21:13 EDT
reproducer as pull request https://github.com/droolsjbpm/drools/pull/261
Comment 3 Mario Fusco 2013-10-01 12:46:38 EDT
Fixed by https://github.com/droolsjbpm/drools/commit/bcbfd88b3

Note that this fix works only if you have kie-ci on the classpath.
Comment 4 JBoss JIRA Server 2013-10-01 12:47:09 EDT
Mario Fusco <mario.fusco@gmail.com> updated the status of jira DROOLS-266 to Resolved
Comment 5 Mario Fusco 2013-10-08 07:02:03 EDT
*** Bug 1008538 has been marked as a duplicate of this bug. ***
Comment 6 Tomas David 2013-12-04 08:08:29 EST
Verified on BRMS 6.0.0.ER5.

Note You need to log in before you can comment on or make changes to this bug.