Bug 101418 - rpm queries result in illegal instruction
rpm queries result in illegal instruction
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks: 97942
  Show dependency treegraph
 
Reported: 2003-07-31 16:29 EDT by Neale Ferguson
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-20 12:48:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neale Ferguson 2003-07-31 16:29:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Description of problem:
Using rpm -q results in Illegal Instruction:

[root@resc020 .vnc]# rpm -qa
Illegal instruction

Jul 31 16:20:31 resc020 kernel: Process rpmq (pid: 1137, task: 000000000c128000,
ksp: 000000000c12bcf8, f: 0)
Jul 31 16:20:31 resc020 kernel: User PSW : 0705e00180000000 0000010000173296
Jul 31 16:20:31 resc020 kernel: User GPRS: 0000010000000000 0000010000173294
0000000080022150 00000000800224a0
Jul 31 16:20:31 resc020 kernel:            0000010000148a50 0000000000000000
00000100001cb664 000000008001cdc0
Jul 31 16:20:31 resc020 kernel:            0000000000000010 000001ffffffe160
0000010000000000 0000000080022150
Jul 31 16:20:31 resc020 kernel:            000000008001e7f0 00000100001ba528
0000010000148a72 000001ffffffdf30
Jul 31 16:20:31 resc020 kernel: User ACRS: 00000100 00408080 00000000 00000000
Jul 31 16:20:31 resc020 kernel:            00000000 00000000 00000000 00000000
Jul 31 16:20:31 resc020 last message repeated 2 times
Jul 31 16:20:31 resc020 kernel: User Code: 10 00 ff ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff ff

This command works fine on s390.

Version-Release number of selected component (if applicable):
rpm-4.2.1-0.29

How reproducible:
Always

Steps to Reproduce:
1. rpm -qa

Additional info:
Comment 1 Jeff Johnson 2003-08-01 12:09:12 EDT
Can you supply a copy of your database?
    cd /var/lib
    tar czvf /tmp/rpmdb-101418.tar.gz rpm
Pointer please, e.g. URL, attachments won't work.
Comment 2 Neale Ferguson 2003-08-01 12:16:38 EDT
All my sites are behind a firewall. Can you e-mail me an address to load it or
an e-mail ID I can send it as an attachment?
Comment 3 Jeff Johnson 2003-08-01 12:17:48 EDT
Then mail <jbj@redhat.com>
Comment 4 Neale Ferguson 2003-08-01 12:45:46 EDT
Your message did not reach some or all of the intended recipients.

      Subject:	rpm db
      Sent:	8/1/2003 12:21 PM

The following recipient(s) could not be reached:

      'jbj@redhat.com' on 8/1/2003 12:26 PM
            The content length of the message is too long for the recipient to
take delivery
	The MTS-ID of the original message is: c=US;a=
;p=SAG;l=USMSG03-030801162042Z-118482
            MSEXCH:IMS:SAG:US4:USMSG06 3903 (000B09B6) Message exceeds size limit

(It's an 8MB file when compressed.)
Comment 5 Neale Ferguson 2003-08-01 12:55:17 EDT
I found a site I could use: Try wget http://vm.marist.edu/~neale/rpmdb.101418
Comment 6 Neale Ferguson 2003-08-01 13:03:20 EDT
BTW the file is a bzip2'ed tarball.
Comment 7 Matt Wilson 2003-08-18 09:48:48 EDT
[msw@keats rpmdb]$ tar jxvf rpmdb.101418
bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Error exit delayed from previous errors
Comment 8 Jeff Johnson 2003-08-20 12:48:06 EDT
The file you provided is not bzip2. Closed becuase of inability
to reproduce.

Feel free to reopen, but I suspect something other than an rpm
"bug" because of the SIGILL failure. rpm-4.2.1 is in active
use on all supported Red Hat platforms dailky, and, well, I believe
I would have heard about a SIGILL problem.

Note You need to log in before you can comment on or make changes to this bug.