This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1014183 - Refolmulate the first paragraph of "Start and Stop Servers"
Refolmulate the first paragraph of "Start and Stop Servers"
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: post-GA
: EAP 6.4.2
Assigned To: David Michael
Petr Kremensky
http://documentation-devel.engineerin...
: Documentation, Triaged
: 1241183 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 09:47 EDT by Petr Kremensky
Modified: 2015-10-20 00:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14874, Administration and Configuration Guide-6.2-1 Build Date: 18-09-2013 13:43:23 Topic ID: 4748-499316 [Latest]
Last Closed: 2015-10-20 00:33:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-01 09:47:31 EDT
Title: Start and Stop Servers

Describe the issue:
We should reformulate the first paragraph a little bit. The rest of chapter is fine.

>You can start and stop servers with the Management CLI or the Management Console. 
you can start only server instances of domain.
>Both management tools allow you to control a single Standalone Server instance, or selectively manage multiple servers across a Managed Domain deployment. 
OK
>If you are using the Management Console, please refer to Section 2.2.2, “Start a Server Using the Management Console” for instructions. 
again, this chapter is valid only for domain mode.
>If you are using the Management CLI, the process varies between Standalone Server and Managed Domain instances. 
OK
Comment 2 Petr Kremensky 2014-02-12 02:16:15 EST
There are still some inaccuracies in http://docbuilder.usersys.redhat.com/22508/#Start_and_Stop_Servers1. 

You cannot start standalone server with any of management tool, you must use scripts to start it (See next paragraph in documentation "A Standalone Server instance can be started by the command line scripts, and shut down from the Management CLI with the shutdown command."). Only instances you can start and stop with management tools are server instances of managed domain, domain itself and all hosts must be started via script too.

Some Management CLI examples:
You can restart and stop the standalone server, domain or server instances of domain.
- reload the standalone
[standalone@localhost:9999 /] reload
- stop the standalone 
[standalone@localhost:9999 /] shutdown
- stop, start and restart the server-one from host named 'master' of managed domain
/host=master/server-config=server-one:stop
/host=master/server-config=server-one:start
/host=master/server-config=server-one:restart
- stop the host (domain controller in this case) named master
/host=master/:shutdown

So:
- you must start the standalone server or managed domain via proper script located in $JBOSS_HOME/bin directory. 
- you can manage and stop (you cannot start it!) standalone server and managed domain via management tools
- you can start and manage managed domain server instances via management tools

Feel free to ask if there is still anything not clear, it may be a little bit tricky :).
Comment 10 Scott Mumford 2015-07-16 23:41:47 EDT
*** Bug 1241183 has been marked as a duplicate of this bug. ***
Comment 12 Petr Kremensky 2015-08-04 02:21:53 EDT
Verified during eap-640-postGA-bulk4-docs check
Revision 6.4.0-35

Note You need to log in before you can comment on or make changes to this bug.