Bug 1014199 - hwcert web server submit traceback if cert ID is not set for an existing certification
hwcert web server submit traceback if cert ID is not set for an existing cert...
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 10:03 EDT by Greg Nichols
Modified: 2014-05-21 15:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: hwcert-client 1.6.5.2-20140328
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1039116 (view as bug list)
Environment:
Last Closed: 2014-05-21 15:18:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fixing submit form (18.83 KB, patch)
2014-03-28 13:42 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2013-10-01 10:03:47 EDT
Description of problem:

When using the hwcert-server web UI to submit results, if "existing" is chosen for the "Certification" drop-down, and ID is left blank, the server gives an error page due to a trace-back.




Version-Release number of selected component (if applicable):

hwcert-client 1.6.5 R18
Comment 1 Greg Nichols 2014-03-28 13:42:56 EDT
Created attachment 879977 [details]
patch fixing submit form

Submit form now validates parameters.

Also, a "new" submit will create both a specification and a certification, then update the id's on the server's store.
Comment 5 errata-xmlrpc 2014-05-21 15:18:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0532.html

Note You need to log in before you can comment on or make changes to this bug.