Bug 1014210 - Fix xrdb to default to -nocpp
Fix xrdb to default to -nocpp
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server-utils (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks: 1014207
  Show dependency treegraph
 
Reported: 2013-10-01 10:17 EDT by Adam Jackson
Modified: 2014-06-18 03:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-server-utils-7.7-4.el7
Doc Type: Release Note
Doc Text:
The xrdb utility manages the X server resource database. Traditionally, the utility invokes the C preprocessor, which is provided by the cpp package, to expand resource files before further operations. However, this feature is disabled by default in Red Hat Enterprise Linux 7 because in most cases, the C preprocessor is not needed. To preserve previous behavior, install cpp and execute xrbd with the "-cpp" option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:56:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Jackson 2013-10-01 10:17:29 EDT
Invoking cpp at all is a misfeature.  We'd like not to ship mcpp, but we also don't want to force gcc's cpp to be installed since it's quite large.  If we change xrdb to default to -nocpp we can remove the dependency on cpp.
Comment 9 Ludek Smid 2014-06-13 05:56:00 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.