Bug 1014310 - Wrong console keymap in use
Wrong console keymap in use
Status: CLOSED DUPLICATE of bug 1001411
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-10-01 13:18 EDT by Marko Myllynen
Modified: 2013-10-01 16:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-10-01 16:06:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2013-10-01 13:18:06 EDT
Description of problem:
After installing F20 Alpha with all defaults except for using Finnish for keyboard, I see LANG="en_US.UTF-8" in /etc/locale.conf and KEYMAP="fi-latin1" in /etc/vconsole.conf but after switching to console and logging in the US keymap is in use, not the Finnish one. After "loadkeys fi" the keymap is Finnish.

NB. Historically kbd has offered fi-latin1 and fi-latin9 but since some Fedora releases ago fi was alias for fi-latin9. Now with F20 both fi and fi-latin1 are symlinks to the xkb converted layout. fi-latin9 is still available under kbd/keymaps/legacy but without path loadkeys won't find it.

Version-Release number of selected component (if applicable):

Additional info:
There are several (remotely) related bugs, possibly this could be a dupe of one of them.

Comment 1 Adam Williamson 2013-10-01 13:25:06 EDT
Does 'systemctl restart systemd-vconsole-setup.service' fix it?
Comment 2 Marko Myllynen 2013-10-01 13:27:09 EDT
(In reply to Adam Williamson from comment #1)
> Does 'systemctl restart systemd-vconsole-setup.service' fix it?

Comment 3 Adam Williamson 2013-10-01 16:06:21 EDT
Then your main bug is:


if the default kbd layout is badly chosen, that would be a separate issue, to file...hum...probably against kbd in the first instance, or possibly langtable.

*** This bug has been marked as a duplicate of bug 1001411 ***

Note You need to log in before you can comment on or make changes to this bug.