Bug 1014350 - Installer does not provide debugging information on errors
Installer does not provide debugging information on errors
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER4
: 6.0.0
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 15:15 EDT by Len DiMaggio
Modified: 2014-02-06 10:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Len DiMaggio 2013-10-01 15:15:29 EDT
Description of problem:

With the Oct 1 ER4 build, I am seeing consistent failures in configuring a server with MySQL 5.1 or 5.5 

The only error reported during the installation is:

Datasource script /opt/local/SOA_servers/SOA6/ER4/jboss-eap-6.1/cli-scripts/jbpmDS-ds-default.cli failed.

There is no additional information available to to the user to debug the root cause of the failure. 


Version-Release number of selected component (if applicable):

ER4

RHEL6

java version "1.7.0_25"
OpenJDK Runtime Environment (rhel-2.3.10.4.el6_4-x86_64)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-10-01 15:16:06 EDT
The full text of the install log displayed is:

Successfully added administrative user account.
Starting Application Server.
=========================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: /opt/local/SOA_servers/SOA6/ER4/jboss-eap-6.1

  JAVA: /usr/lib/jvm/jre-1.7.0-openjdk.x86_64//bin/java

  JAVA_OPTS: -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true

=========================================================================

12:41:28,053 INFO  [org.jboss.modules] (main) JBoss Modules version 1.2.0.Final-redhat-1
Trying to connect to Management Interface...(1/5).
12:41:29,486 INFO  [org.jboss.as.process.Host Controller.status] (main) JBAS012017: Starting process 'Host Controller'
[Host Controller] 12:41:31,167 INFO  [org.jboss.modules] (main) JBoss Modules version 1.2.0.Final-redhat-1
[Host Controller] 12:41:31,650 INFO  [org.jboss.msc] (main) JBoss MSC version 1.0.4.GA-redhat-1
[Host Controller] 12:41:31,962 INFO  [org.jboss.as] (MSC service thread 1-7) JBAS015899: JBoss Red Hat JBoss Fuse Service Works 6.0.0.ER4-redhat-1 (AS 7.2.0.Final-redhat-8) starting
[Host Controller] 12:41:34,075 INFO  [org.xnio] (MSC service thread 1-1) XNIO Version 3.0.7.GA-redhat-1
[Host Controller] 12:41:34,087 INFO  [org.xnio.nio] (MSC service thread 1-1) XNIO NIO Implementation Version 3.0.7.GA-redhat-1
[Host Controller] 12:41:34,102 INFO  [org.jboss.remoting] (MSC service thread 1-1) JBoss Remoting version 3.2.16.GA-redhat-1
[Host Controller] 12:41:34,121 INFO  [org.jboss.as] (Controller Boot Thread) JBAS010902: Creating http management service using network interface (management) port (9990) securePort (-1)
[Host Controller] 12:41:34,472 INFO  [org.jboss.as.remoting] (MSC service thread 1-8) JBAS017100: Listening on 127.0.0.1:9999
Trying to connect to Management Interface...(2/5).
Connected to Management Interface.
Datasource script /opt/local/SOA_servers/SOA6/ER4/jboss-eap-6.1/cli-scripts/jbpmDS-ds-default.cli failed.
Running onfail Server Check.
Shutting server down.
Trying to connect to Management Interface...(1/5).
Connected to Management Interface.
12:41:40,229 INFO  [org.jboss.as.process] (Thread-8) JBAS012016: Shutting down process controller
12:41:40,230 INFO  [org.jboss.as.process.Host Controller.status] (Thread-8) JBAS012018: Stopping process 'Host Controller'
[Host Controller] 12:41:40,384 INFO  [org.jboss.as] (MSC service thread 1-2) JBAS015950: JBoss Red Hat JBoss Fuse Service Works 6.0.0.ER4-redhat-1 (AS 7.2.0.Final-redhat-8) stopped in 90ms
12:41:40,411 INFO  [org.jboss.as.process.Host Controller.status] (reaper for Host Controller) JBAS012010: Process 'Host Controller' finished with an exit status of 0
12:41:40,412 INFO  [org.jboss.as.process] (Thread-8) JBAS012015: All processes finished; exiting
Comment 2 Thomas Hauser 2013-10-01 15:42:38 EDT
Hmm. This looks like the very first .cli job is failing. It may be related to the server not starting fast enough to successfully complete the issued command. I will look into this. We have set the jboss-cli to "silent" because otherwise, a very large amount of output is produced. I guess this would be preferable to no output.
Comment 3 Thomas Hauser 2013-10-01 15:43:56 EDT
I agree with the sentiment of this BZ, however. More information needs to be provided for the user.
Comment 4 Francisco Canas 2013-10-02 12:20:12 EDT
As a starting point, the installer GUI now makes use of color to highlight error messages for the user during the processing panel. This will at least help errors stand out against the large amount of output.

http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=9a12f4478b33bf419f8a877831b4b84664d3c6eb
Comment 5 Thomas Hauser 2013-10-10 14:36:20 EDT
The installer now outputs all cli commands, all server.log content (with default logging levels), and the output of all additional external commands (add-user.sh, s-ramp jar). This is saved in a file located at <install-path>/InstallationLog.txt

The coloring of errors will not be present until post-beta.
Comment 6 Len DiMaggio 2014-01-06 08:03:10 EST
Verified in ER8.

Note You need to log in before you can comment on or make changes to this bug.