Bug 1014351 - Coverity fixes - 12023, 12024, and 12025
Coverity fixes - 12023, 12024, and 12025
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks: 1061410
  Show dependency treegraph
 
Reported: 2013-10-01 15:16 EDT by Rich Megginson
Modified: 2014-10-14 03:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:51:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2013-10-01 15:16:15 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47540

fix newer coverity issues 12023, 12024, and 12025

ldclt.c: 12023 Ignoring number of bytes read
The number of bytes copied into the buffer can be smaller than the requested number and the buffer can potentially be accessed out of range.
In basicInit: Value returned from a function and indicating the number of bytes read is ignored.

roles_cache.c: 12024 Resource leak
The system resource will not be reclaimed and reused, reducing the future availability of the resource.
In roles_cache_create_object_from_entry: Leak of memory or pointers to system resources

dblayer.c: 12025 Wrong sizeof argument
The wrong sizeof value is used in an expression or as argument to a function. The result is an incorrect value that may cause unexpected program behaviors.
In read_metadata: The sizeof operator is invoked on the wrong argument
Comment 3 Sankar Ramalingam 2014-08-19 10:02:02 EDT
Request dev to mark the bug as Verified from Coverity reports.
Comment 4 Noriko Hosoi 2014-08-19 10:54:46 EDT
Covscan passed with no defect reports (except one false positive).
http://cov01.lab.eng.brq.redhat.com/covscanhub/waiving/et_mapping/6248/

Please mark VERIFIED.
Comment 5 Sankar Ramalingam 2014-08-19 13:42:08 EDT
As per Noriko's previous comment, marking the bug as Verified.
Comment 6 errata-xmlrpc 2014-10-14 03:51:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.