Bug 1014354 - Coverity fixes - 12023, 12024, and 12025
Coverity fixes - 12023, 12024, and 12025
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 15:22 EDT by Rich Megginson
Modified: 2014-06-17 23:00 EDT (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.1.6-5.el7
Doc Type: Bug Fix
Doc Text:
These were introduced by the bug fixes to the 389-ds-base version for rhel-7.0. No need to doc.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:11:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2013-10-01 15:22:50 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47540

fix newer coverity issues 12023, 12024, and 12025

ldclt.c: 12023 Ignoring number of bytes read
The number of bytes copied into the buffer can be smaller than the requested number and the buffer can potentially be accessed out of range.
In basicInit: Value returned from a function and indicating the number of bytes read is ignored.

roles_cache.c: 12024 Resource leak
The system resource will not be reclaimed and reused, reducing the future availability of the resource.
In roles_cache_create_object_from_entry: Leak of memory or pointers to system resources

dblayer.c: 12025 Wrong sizeof argument
The wrong sizeof value is used in an expression or as argument to a function. The result is an incorrect value that may cause unexpected program behaviors.
In read_metadata: The sizeof operator is invoked on the wrong argument
Comment 3 Sankar Ramalingam 2014-01-31 22:44:00 EST
Is this sanity only verification?
Comment 4 Rich Megginson 2014-02-03 10:31:45 EST
(In reply to Sankar Ramalingam from comment #3)
> Is this sanity only verification?

Yes, and checking coverity to see there are no issues.
Comment 5 Sankar Ramalingam 2014-02-03 23:34:29 EST
(In reply to Rich Megginson from comment #4)
> (In reply to Sankar Ramalingam from comment #3)
> > Is this sanity only verification?
> 
> Yes, and checking coverity to see there are no issues.

How do I check coverity reports 389-ds-base?
Comment 6 Noriko Hosoi 2014-02-04 00:55:14 EST
This is the 389-ds link.  The page is now empty.

http://vm-095.idm.lab.bos.redhat.com:8080/reports.htm#v10120/p10014
Comment 7 Sankar Ramalingam 2014-02-07 08:33:45 EST
(In reply to Noriko Hosoi from comment #6)
> This is the 389-ds link.  The page is now empty.
I don't have an access to this page. Should I go ahead and mark the bug as verified since there are no Coverity issues reported?
> 
> http://vm-095.idm.lab.bos.redhat.com:8080/reports.htm#v10120/p10014
Comment 8 Rich Megginson 2014-02-07 09:20:13 EST
Yes, please mark as VERIFIED.
Comment 9 Sankar Ramalingam 2014-02-13 06:46:07 EST
As per Rich's comment, marking the bug as Verified.
Comment 10 Ludek Smid 2014-06-13 08:11:18 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.