Bug 1014372 - Jboss is defaulted to wrong directory during automatic install
Jboss is defaulted to wrong directory during automatic install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity low
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Pavel Stehlik
integration
: Triaged
: 1014371 1040016 1044978 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 16:32 EDT by Bill Sanford
Modified: 2013-12-19 10:20 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 08:57:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2013-10-01 16:32:01 EDT
Description of problem:
Using the RHEV-M automatic install "rhevm-setup --config=rhevm-answer," I get an error where the Jboss home directory is defaulted to /usr/share/jboss-as and the automatic install, fails. 

If I use rhevm-setup --config=rhevm-answer --jboss-home=/usr/share/jbossas there is no error and the automatic install works. 

There should be an entry setting the Jboss home directory in the answer file or the rhevm-setup defaults to the right directory.

Version-Release number of selected component (if applicable):
RHEV-M 3.3 (is16)

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

This is the complete answer file from RHEV-M 3.3 (is16)

[environment:default]
OVESETUP_CORE/engineStop=none:None
OVESETUP_DIALOG/confirmSettings=bool:True
OVESETUP_DB/database=str:engine
OVESETUP_DB/fixDbViolations=none:None
OVESETUP_DB/secured=bool:False
OVESETUP_DB/host=str:localhost
OVESETUP_DB/user=str:engine
OVESETUP_DB/securedHostValidation=bool:False
OVESETUP_DB/password=str:9075CaFv
OVESETUP_DB/port=int:5432
OVESETUP_SYSTEM/nfsConfigEnabled=bool:False
OVESETUP_SYSTEM/memCheckEnabled=bool:True
OVESETUP_PKI/organization=str:spice.ml2.eng.bos.redhat.com
OVESETUP_CONFIG/isoDomainName=none:None
OVESETUP_CONFIG/isoDomainMountPoint=none:None
OVESETUP_CONFIG/adminPassword=str:REDhat2013!
OVESETUP_CONFIG/applicationMode=str:virt
OVESETUP_CONFIG/firewallManager=str:iptables
OVESETUP_CONFIG/websocketProxyConfig=bool:False
OVESETUP_CONFIG/fqdn=str:rhevm.spice.ml2.eng.bos.redhat.com
OVESETUP_CONFIG/storageType=str:iscsi
OVESETUP_PROVISIONING/postgresProvisioningEnabled=bool:True
OVESETUP_APACHE/configureRootRedirection=bool:True
OVESETUP_APACHE/configureSsl=bool:True
OSETUP_RPMDISTRO/requireRollback=none:None
OSETUP_RPMDISTRO/enableUpgrade=none:None
OVESETUP_AIO/configure=none:None
OVESETUP_AIO/storageDomainDir=none:None
Comment 1 Itamar Heim 2013-10-02 00:23:19 EDT
*** Bug 1014371 has been marked as a duplicate of this bug. ***
Comment 2 Alon Bar-Lev 2013-10-02 03:45:57 EDT
You should use --config-append
Comment 3 Sandro Bonazzola 2013-10-02 03:53:31 EDT
(In reply to Alon Bar-Lev from comment #2)
> You should use --config-append

I think we should document better the difference between --config and --config-append: from --help:

     --config=file
        Load configuration files.
    --config-append=file
        Load extra configuration files.

It doesn't explain why using --config-append works and --config require you to specify other parameters in order to have a  working instance.
Comment 4 Alon Bar-Lev 2013-10-02 03:56:16 EDT
(In reply to Sandro Bonazzola from comment #3)
> (In reply to Alon Bar-Lev from comment #2)
> > You should use --config-append
> 
> I think we should document better the difference between --config and
> --config-append: from --help:
> 
>      --config=file
>         Load configuration files.
>     --config-append=file
>         Load extra configuration files.
> 
> It doesn't explain why using --config-append works and --config require you
> to specify other parameters in order to have a  working instance.

No problem, document whatever you want.

--config - replaces system configuration.
--config-append - appends configuration into whatever exists.
Comment 5 Bill Sanford 2013-10-02 10:16:23 EDT
I installed rhevm and then did "rhevm-setup --generate-answer=file" to get the values to use in the automatic install. I then reinstalled the RHEL servers to install and configured rhevm from scratch, using that answer file. 

Step by step:

1. Install rhevm on RHEL 6.5.
2. rhevm-setup --generate-answer=rhevm-answer. Save answer file.
3. Reinstall RHEL 6.5 from PXE on same machine and wipe out previous install.
4. Reinstall rhevm on RHEL 6.5.
5. rhevm-setup --config=/home/test/Desktop/rhevm-answer

How will the --config or the --config-append work in the scenario from the original comment? The *only* time I get this to work is when I add "--jboss-home=/usr/share/jbossas" 

There is a "/usr/share/jboss-as" value, hard coded somewhere that the install is picking up and needs to be changed to the new default value.
Comment 6 Alon Bar-Lev 2013-10-02 10:19:54 EDT
(In reply to Bill Sanford from comment #5)
> 5. rhevm-setup --config=/home/test/Desktop/rhevm-answer

1. Please use engine-setup and not rhevm-setup. rhevm-setup is obsoleted.

2. please use --config-append and not --config per comment#2.
Comment 7 Sandro Bonazzola 2013-11-05 08:57:57 EST
(In reply to Alon Bar-Lev from comment #6)
> (In reply to Bill Sanford from comment #5)
> > 5. rhevm-setup --config=/home/test/Desktop/rhevm-answer
> 
> 1. Please use engine-setup and not rhevm-setup. rhevm-setup is obsoleted.
> 
> 2. please use --config-append and not --config per comment#2.

Closing as not a bug.
Comment 8 Sandro Bonazzola 2013-12-12 02:46:56 EST
*** Bug 1040016 has been marked as a duplicate of this bug. ***
Comment 9 Sandro Bonazzola 2013-12-19 10:20:26 EST
*** Bug 1044978 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.