Bug 1014381 - systemd crash on resume after suspend
systemd crash on resume after suspend
Status: CLOSED DUPLICATE of bug 1010603
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 16:54 EDT by Milan Bouchet-Valat
Modified: 2013-10-02 09:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 09:44:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 61781 None None None Never

  None (edit)
Description Milan Bouchet-Valat 2013-10-01 16:54:27 EDT
systemd crashes from time to time (about 1 failure for 4 successes) when returning from suspend. Please ask if you need more information.

This is on an eepc Seashell series.
systemd is 204-15.fc19.i686
Kernel is 3.11.1-200.fc19.i686


gdb stacktrace:

#0  0xb76ac424 in __kernel_vsyscall ()
#1  0xb757db86 in __pause_nocancel () at ../sysdeps/unix/syscall-template.S:81
#2  0xb7751bc5 in freeze () at ../src/shared/util.c:3438
#3  0xb76df2dc in crash (sig=11) at ../src/core/main.c:193
#4  <signal handler called>
#5  0xb750bd28 in __strnlen_sse2 () from /lib/libc.so.6
#6  0xb73f575f in vfprintf () from /lib/libc.so.6
#7  0xb74be080 in __vsnprintf_chk () from /lib/libc.so.6
#8  0xb74bdfa7 in __snprintf_chk () from /lib/libc.so.6
#9  0xb77448e6 in snprintf (
    __fmt=0xb779f3bc "PRIORITY=%i\nSYSLOG_FACILITY=%i\n%s%.*s%s%s%.*i%s%s%.*s%s%s%.*s%sSYSLOG_IDENTIFIER=%s\n", __n=2048, 
    __s=0xbfff37bc "PRIORITY=6\nSYSLOG_FACILITY=3\nCODE_FILE=")
    at /usr/include/bits/stdio2.h:64
#10 log_do_header (
    header=header@entry=0xbfff37bc "PRIORITY=6\nSYSLOG_FACILITY=3\nCODE_FILE=", level=level@entry=30, file=file@entry=0xb776e98f "../src/core/manager.c", 
    line=line@entry=1644, 
    func=func@entry=0xb77700c2 <__func__.12899> "process_event", 
    object_name=object_name@entry=0x0, object=object@entry=0x0, size=2048)
    at ../src/shared/log.c:441
#11 0xb774613c in log_struct_internal (level=30, level@entry=6, 
    file=file@entry=0xb776e98f "../src/core/manager.c", line=line@entry=1644, 
    func=func@entry=0xb77700c2 <__func__.12899> "process_event", 
    format=format@entry=0xb776f89c "MESSAGE_ID=%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x") at ../src/shared/log.c:746
#12 0xb76e6606 in process_event (ev=0xbfff4078, m=0xb90deea0)
    at ../src/core/manager.c:1641
#13 manager_loop (m=0xb90deea0) at ../src/core/manager.c:1755
#14 0xb76dc1b0 in main (argc=5, argv=0xbfff45e4) at ../src/core/main.c:1734
Comment 1 Kay Sievers 2013-10-01 22:04:26 EDT
Might be this kernel issue:
  https://bugzilla.kernel.org/show_bug.cgi?id=61781
Comment 2 Milan Bouchet-Valat 2013-10-02 09:42:49 EDT
Thanks, I've suspended about 10 times using kernel 3.10 and indeed the bug did not happen. So this looks like the same problem.
Comment 3 Milan Bouchet-Valat 2013-10-02 09:44:41 EDT

*** This bug has been marked as a duplicate of bug 1010603 ***

Note You need to log in before you can comment on or make changes to this bug.