Bug 101439 - error messages when starting xmms
Summary: error messages when starting xmms
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-artwork   
(Show other bugs)
Version: beta1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-01 01:37 UTC by Chris Ricker
Modified: 2013-03-13 04:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 00:18:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2003-08-01 01:37:17 UTC
I get the following when starting xmms on a severn beta1 system updated to rawhide:

[kaboom@skuld kaboom]$ xmms
mcop warning: user defined signal handler found for SIG_PIPE, overriding

Gtk-WARNING **: libgdk_pixbuf.so.2: cannot open shared object file: No such file
or directory

Gtk-WARNING **: libgdk_pixbuf.so.2: cannot open shared object file: No such file
or directory

This is with

[kaboom@skuld kaboom]$ rpm -q xmms
xmms-1.2.7-23.p
[kaboom@skuld kaboom]$

Comment 1 Bill Nottingham 2003-08-01 01:52:54 UTC
The first is from arts.

The gdk-pixbuf messages are from some plugin, although it doesn't appear to be
one we ship by default. Can you find a xmms plugin in your plugin dir linked
against that lib?

Comment 2 Chris Ricker 2003-08-01 02:01:37 UTC
Hmm, I'm configured to use esound, not arts (and this is under openbox), so I'm
not sure why that's entering in then....

I also can't find any plugins which link against gdk-pixbuf:

[kaboom@skuld kaboom]$ ldd /usr/lib/xmms/*/* | grep gdk-pixbuf
ldd: warning: you do not have execution permission for
`/usr/lib/xmms/Output/libartsout.a'
[kaboom@skuld kaboom]$ 

Comment 3 Bill Nottingham 2003-08-01 02:04:11 UTC
gdk*_*pixbuf, although that may not help.

xmms tries arts on startup if it sees artsd is running.

Comment 4 Chris Ricker 2003-08-01 02:08:29 UTC
Oops, that should be:

[kaboom@skuld kaboom]$ ldd /usr/lib/xmms/*/* | grep gdk_pixbuf
ldd: warning: you do not have execution permission for
`/usr/lib/xmms/Output/libartsout.a'
[kaboom@skuld kaboom]$ 

Huh, it looks like the 2nd set of errors about gdk_pixbuf is generic to all gtk
apps:

[kaboom@skuld kaboom]$ ethereal

Gtk-WARNING **: libgdk_pixbuf.so.2: cannot open shared object file: No such file
or directory
[kaboom@skuld kaboom]$ 


Comment 5 Chris Ricker 2003-08-01 02:09:57 UTC
I don't have artsd running, though:

[kaboom@skuld kaboom]$ ps -ef | grep arts
kaboom    3044  2501  0 20:09 pts/2    00:00:00 grep arts
[kaboom@skuld kaboom]$ 

Comment 6 Bill Nottingham 2003-08-01 02:15:09 UTC
Are you using a particular theme?

Comment 7 Bill Nottingham 2003-08-01 02:16:24 UTC
The arts message comes from the arts library linked into xmms itself. :/

Comment 8 Chris Ricker 2003-08-01 02:21:22 UTC
Theme in what? In xmms, I'm just using the standard skin.

I'm not running Gnome or KDE, so there's no theming there (and thats also why no
artsd) -- my window manager is openbox

Also, the gdk_pixbuf error is not universal to all gtk apps. memprof doesn't do
it, though gimp does



Comment 9 Owen Taylor 2003-08-01 13:44:14 UTC
memprof is a GTK+-2.0 app; the warning for you is appearing for
all GTK+-1.x apps.

The problem is with redhat-artwork - if you look at /etc/skel/.gtkrc
it has:

include "/usr/share/themes/Bluecurve/gtk/gtkrc"

Apparently redhat-artwork was intentionally stripped of all dependencies:

$ ldd /usr/lib/gtk/themes/engines/libbluecurve.so | grep gdk_pixbuf
        libgdk_pixbuf.so.2 => /usr/lib/libgdk_pixbuf.so.2 (0x40022000)

$ rpm -q --requires redhat-artwork
redhat-logos >= 1.1.10
/usr/lib/qt-3.1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

I think this is so you can have redhat-artwork installed without 
having every toolkit that it installs engines for installed.

I don't really know how we can fix this bug; I can't add a
dependency on gdk-pixbuf to the gtk+ package because gdk-pixbuf
requires gtk+ to build. Maybe add the dependency to xmms and
the GIMP as being the only GTK+-1.2 applications anyone will
ever run on Severn... (Half a joke, half a serious suggestion.)

If you install the gdk-pixbuf RPM, the warning will certainly
go away.

Comment 10 Havoc Pennington 2003-08-01 18:48:33 UTC
Adding the dep to xmms and gimp is the only thing I can think of.

Comment 11 Bill Nottingham 2003-08-01 19:17:28 UTC
xmms/gimp don't care what the gtk+ theme is, so they shouldn't have deps on
however the gtk+ theme is implemented.

Comment 12 Owen Taylor 2003-08-28 16:34:22 UTC
No way a GTK+ bug in any case, as explained above.

Comment 13 Alexander Larsson 2003-08-29 07:56:36 UTC
Dunno how to solve this...

Comment 14 Bill Nottingham 2006-08-07 15:56:25 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still running
Red Hat Linux, you are strongly advised to upgrade to a current Fedora Core
release or Red Hat Enterprise Linux or comparable. Some information on which
option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks. Please check if this
issue is still present in a current Fedora Core release. If so, please change
the product and version to match, and check the box indicating that the
requested information has been provided. Note that any bug still open against
Red Hat Linux by the end of 2006 will be closed as 'CANTFIX'. Thanks again for
your help.


Comment 16 Bill Nottingham 2007-07-27 00:18:30 UTC
Closing as CANTFIX.


Note You need to log in before you can comment on or make changes to this bug.