Bug 1014398 - Incorrect Requires: for pyudev, causing neutron to crash on startup
Incorrect Requires: for pyudev, causing neutron to crash on startup
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
4.0
Unspecified Unspecified
urgent Severity urgent
: beta
: 4.0
Assigned To: Lon Hohberger
Rami Vaknin
network
: AutoVerified, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 17:45 EDT by Lon Hohberger
Modified: 2016-04-26 12:29 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-0.3.3.b3.el6ost
Doc Type: Bug Fix
Doc Text:
Do not document; internal fix only that customers would not see..
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:25:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2013-10-01 17:45:40 EDT
Description of problem:

Neutron requires python-pyudev, but does not have it in the spec file.  This causes packstack to abort during installation.

Version-Release number of selected component (if applicable): openstack-neutron-2013.2-0.3.2.b3.el6ost.noarch

How reproducible: 100%

Steps to Reproduce:
1. Try to run Packstack from RHOS 4.0
2. That explodes, so try to run neutron-server

Actual results: Rain of fire and ashes

[root@localhost ~]# rpm -e pyudev
error: package pyudev is not installed
[root@localhost ~]# neutron-server 
Traceback (most recent call last):
  File "/usr/bin/neutron-server", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pyudev

Expected results: Packstack succeeds and neutron runs.


Additional info: CI and my tests are unable to run.
Comment 1 Lon Hohberger 2013-10-01 17:47:06 EDT
Actually, it's in the rpm spec, just in the wrong place.
Comment 2 Lon Hohberger 2013-10-01 18:23:28 EDT
I verified that this worked with a simple packstack installation on an all-in-one.
Comment 5 Ofer Blaut 2013-10-16 13:23:31 EDT
We have installed latest build on different setups and neutron server is running 


[root@puma04 ~]# openstack-status 
== Nova services ==
openstack-nova-api:           active
openstack-nova-cert:          active
openstack-nova-compute:       dead (disabled on boot)
openstack-nova-network:       dead (disabled on boot)
openstack-nova-scheduler:     active
openstack-nova-volume:        dead (disabled on boot)
openstack-nova-conductor:     active
== Glance services ==
openstack-glance-api:         active
openstack-glance-registry:    active
== Keystone service ==
openstack-keystone:           active
== Horizon service ==
openstack-dashboard:          active
== neutron services ==
neutron-server:               active
neutron-openvswitch-agent:    active
== Cinder services ==
openstack-cinder-api:         active
openstack-cinder-scheduler:   active
openstack-cinder-volume:      active
== Ceilometer services ==
openstack-ceilometer-api:     active
openstack-ceilometer-central: active
openstack-ceilometer-compute: dead (disabled on boot)
openstack-ceilometer-collector:active
== Support services ==
mysqld:                       active
openvswitch:                  active
messagebus:                   active
tgtd:                         active
qpidd:                        active
memcached:                    active
== Keystone users ==
Warning keystonerc not sourced
[root@puma04 ~]# rpm -e pyudev
error: package pyudev is not installed
[root@puma04 ~]# rpm -qa | grep packstack
openstack-packstack-2013.2.1-0.6.dev763.el6ost.noarch
packstack-modules-puppet-2013.2.1-0.6.dev763.el6ost.noarch
[root@puma04 ~]# rpm -qa | grep neutron
python-neutron-2013.2-0.3.3.b3.el6ost.noarch
openstack-neutron-2013.2-0.3.3.b3.el6ost.noarch
openstack-neutron-openvswitch-2013.2-0.3.3.b3.el6ost.noarch
python-neutronclient-2.2.6-1.el6ost.noarch
Comment 8 errata-xmlrpc 2013-12-19 19:25:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.