Bug 1014412 - The skip broken option, if set in the preferences tab, shows as checked in the options tab, but is not used
The skip broken option, if set in the preferences tab, shows as checked in th...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 19:23 EDT by Peter Trenholme
Modified: 2013-11-10 02:08 EST (History)
1 user (show)

See Also:
Fixed In Version: yumex-3.0.13-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 20:54:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2013-10-01 19:23:42 EDT
Description of problem: When I use the "Preferences" tab to set "Skip Broken" to true, when yumex is restarted, the "Options" tab shows it checked, but the option is not passed to the yun backend. If I uncheck the option and re-check it in the "Options" tab, it is correctly passed.


Version-Release number of selected component (if applicable):
3.0.12

How reproducible:
Every time (also on F-19 and F-20)

Steps to Reproduce:
1. Set the preference
2. Restart yumex
3. Try to run an update of "Rawhide" when there is a dependency problem. (This is, as you know, a common problem with Rawhide.)

Actual results:
yum-backend aborts update

Expected results:
Broken updates skipped

Additional info:
Note the comment under "how reproducible" that this "bug" is in the F-19 and F-20 yumex versions.

I suggested a severity of "medium" for this since the workaround is fairly simple, and broken dependencies are quite rare in active distributions.
Comment 2 Peter Trenholme 2013-10-02 18:24:01 EDT
O.K., that version fixed the problem.

@Tim: Your make instructions had an extra "get" in the line. You might want to modify the page if you send the link to anyone else.
Comment 3 Tim Lauridsen 2013-10-03 10:56:31 EDT
Thanks, I have fix the page now :)
Comment 4 Fedora Update System 2013-10-16 02:24:12 EDT
yumex-3.0.13-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/yumex-3.0.13-1.fc20
Comment 5 Fedora Update System 2013-10-16 02:24:33 EDT
yumex-3.0.13-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/yumex-3.0.13-1.fc19
Comment 6 Fedora Update System 2013-10-17 16:27:31 EDT
Package yumex-3.0.13-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yumex-3.0.13-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19167/yumex-3.0.13-1.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-10-23 20:54:19 EDT
yumex-3.0.13-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-11-10 02:08:04 EST
yumex-3.0.13-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.