Bug 1014441 - submit traceback on printing catalog error code
submit traceback on printing catalog error code
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 1001233
  Show dependency treegraph
 
Reported: 2013-10-01 23:42 EDT by Brian Brock
Modified: 2013-11-13 05:01 EST (History)
3 users (show)

See Also:
Fixed In Version: hwcert-client 1.6.5-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 05:01:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalog patch to print error code as a string (515 bytes, patch)
2013-10-02 10:07 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Comment 3 Greg Nichols 2013-10-02 10:07:28 EDT
Created attachment 806502 [details]
catalog patch to print error code as a string
Comment 10 Brian Brock 2013-10-08 12:26:16 EDT
That works, an incorrect passwd fails (as expected) with an incorrect password but does not throw a traceback.  Note that we're only prompted once for the password, instead of being allowed to retry (3 times?) after an incorrect passwd is supplied.  We can discuss and I'll file separately if that's a possible feature later.

bugfix verified in -21.el6


What certification is this system being tested for? (new|existing|none) new
response: new
Red Hat Catalog User Name: bbrock@redhat.com
response: bbrock@redhat.com
Password: 
Error: could not open a new certification:
    Fault code: 300
    Fault string: The username or password you entered is not valid.
What certification is this system being tested for? (new|existing|none) new
response: new
Error: could not open a new certification:
    Fault code: 300
    Fault string: The username or password you entered is not valid.
What certification is this system being tested for? (new|existing|none) new
response: new
Error: could not open a new certification:
    Fault code: 300
    Fault string: The username or password you entered is not valid.
Comment 12 errata-xmlrpc 2013-11-13 05:01:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1515.html

Note You need to log in before you can comment on or make changes to this bug.