Bug 1014452 - Regression: Inline tags in <abstract>s are escaped and rendered as text
Regression: Inline tags in <abstract>s are escaped and rendered as text
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core (Show other bugs)
1.1
Unspecified Unspecified
urgent Severity urgent
: ---
: 1.2
Assigned To: Lee Newson
:
Depends On:
Blocks: 1012194 1019013
  Show dependency treegraph
 
Reported: 2013-10-02 01:22 EDT by Ruediger Landmann
Modified: 2013-10-17 19:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 19:45:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2013-10-02 01:22:36 EDT
Description of problem:
Inline tags that are children of <abstract> get processed as plain text when built into the Book_Info.xml file

Version-Release number of selected component (if applicable):
1.1

How reproducible:
100%

Steps to Reproduce:
1. Specify an inline tag in the "Abstract:" parameter of a topic map. For example:

Abstract: The <citetitle>Foo Guide</title> describes how you...

Actual results:
This gets built into the Book_Info.xml file as:

<abstract><para>
The &lt;citetitle&gt;Foo Guide&lt;/citetitle&gt; describes how you
<para></abstract>

and rendered in HTML as:

The <citetitle>Foo Guide</title> describes how you...

Expected results:
Inline tags are not escaped and render properly.

Additional info:
Comment 1 Lee Newson 2013-10-02 21:20:26 EDT
This used to work and there are a few people using it already so I'm marking this as a regression.
Comment 2 Lee Newson 2013-10-09 00:44:23 EDT
Fixed in 1.2-SNAPSHOT, Build 201310091335

This was caused by the work we did in 1.0 to escape values so that they can be used in XML, as previously using characters such as "&" would have cause a validation error. I've updated abstract so that it will ignore xml elements and only escape < or > when they are on their own.
Comment 4 Matthew Casperson 2013-10-14 20:09:35 EDT
Tested with invalid XML. Publican throws and error about mismatched tags. Ideally we should have some kind of validation in the CCMS for this, but I think a Publican validation error is sufficient for now.

Tested with 

Abstract = This <citetitle>Foo Guide</citetitle> represents the <emphasis>workflows</emphasis> and methods which generate the best results for <application>CCMS-generated</application> documentation, and should be used as the first point of guidance for using PressGang CCMS

Abstract was displayed correctly.

Note You need to log in before you can comment on or make changes to this bug.