This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1014473 - denyhosts fails to start, for lack of /var/log/secure
denyhosts fails to start, for lack of /var/log/secure
Status: CLOSED DUPLICATE of bug 988163
Product: Fedora
Classification: Fedora
Component: denyhosts (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 03:38 EDT by David Jansen
Modified: 2014-11-11 20:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-11 05:13:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2013-10-02 03:38:55 EDT
Description of problem:
denyhosts in Fedora 20 alpha fails to start, because there is no /var/log/secure . no doubt due to the fact, that logging is handled through the systemd journal in stead of rsyslog

Version-Release number of selected component (if applicable):
denyhosts-2.6-29.fc20.noarch

How reproducible:

Steps to Reproduce:
1. install denyhosts
2. enable and start the denyhosts.service
3.

Actual results:

# systemctl status denyhosts.service
denyhosts.service - SSH log watcher
   Loaded: loaded (/usr/lib/systemd/system/denyhosts.service; enabled)
   Active: failed (Result: exit-code) since Wed 2013-10-02 09:22:11 CEST; 1min 11s ago
  Process: 22955 ExecStart=/usr/bin/denyhosts.py --daemon --config=/etc/denyhosts.conf (code=exited, status=1/FAILURE)
  Process: 22952 ExecStartPre=/bin/rm -f /run/lock/subsys/denyhosts (code=exited, status=0/SUCCESS)

Oct 02 09:22:10 eendracht.strw.leidenuniv.nl systemd[1]: Starting SSH log watcher...
Oct 02 09:22:11 eendracht.strw.leidenuniv.nl denyhosts.py[22955]: Can't read: /var/log/secure
Oct 02 09:22:11 eendracht.strw.leidenuniv.nl denyhosts.py[22955]: [Errno 2] No such file or directory: '/var/log/secure'
Oct 02 09:22:11 eendracht.strw.leidenuniv.nl denyhosts.py[22955]: Error deleting DenyHosts lock file: /var/lock/subsys/denyhosts
Oct 02 09:22:11 eendracht.strw.leidenuniv.nl denyhosts.py[22955]: [Errno 2] No such file or directory: '/var/lock/subsys/denyhosts'
Oct 02 09:22:11 eendracht.strw.leidenuniv.nl systemd[1]: denyhosts.service: control process exited, code=exited status=1
Oct 02 09:22:11 eendracht.strw.leidenuniv.nl systemd[1]: Failed to start SSH log watcher.
Oct 02 09:22:11 eendracht.strw.leidenuniv.nl systemd[1]: Unit denyhosts.service entered failed state.


Expected results:
a running denyhosts daemon

Additional info:
Comment 1 Kevin Raymond 2013-12-11 05:08:24 EST
Issue still there
Comment 2 Kevin Raymond 2013-12-11 05:13:24 EST

*** This bug has been marked as a duplicate of bug 988163 ***
Comment 3 Karthic 2014-11-08 13:07:15 EST
My server was attacked brutally and I was searching for a solution. I could not see a good solution except the whole thing sucks. I worked on my solution and would like to share with any one having the same issue and needs a solution.

I added a tactical command to /var/spool/cron/root to run every five minutes. It works now. Here is the command:

journalctl -u sshd --since=today | grep -e Failed >/var/log/secure
Comment 4 Jason Tibbitts 2014-11-11 20:09:25 EST
It is, like, a whole lot easier to install a syslog daemon.

Note You need to log in before you can comment on or make changes to this bug.