Bug 1014501 - InvalidPluginConfigurationException in agent log - product type is JBoss EAP 6 instead of JBoss JPP 6
InvalidPluginConfigurationException in agent log - product type is JBoss EAP ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JPP (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ER04
: JON 3.2.0
Assigned To: Thomas Segismont
Martin Vecera
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 04:54 EDT by mgottval
Modified: 2014-09-14 20:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 06:50:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mgottval 2013-10-02 04:54:22 EDT
I installed JON 3.2.ER02 - copy all the *.jar plugins from jon-plugin-pack-jpp-3.2.0.ER2 into JON-server/plugins, install and start the server. Downloaded and start rhq-agent. JPP is running and is discovered by JON-server, I imported it from discovery queue.

In the rhq-agent log, there appears an InvalidPluginConfigurationException:

org.rhq.core.pluginapi.inventory.InvalidPluginConfigurationException: Failed to start component for resource Resource[id=10002, uuid=f4d26827-242a-4c1a-aeb2-4f754bde1689, type={JBossAS7}JBossAS7 Standalone Server, key=hostConfig: /home/mgottval/GateIn/jboss-jpp-6.1/standalone/configuration/standalone.xml, name=JPP (127.0.0.1:9990), parent=localhost.localdomain, version=JPP 6.1.0].
	at org.rhq.core.pc.inventory.InventoryManager.activateResource(InventoryManager.java:1937)
	at org.rhq.core.pc.inventory.InventoryManager.updatePluginConfiguration(InventoryManager.java:642)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.rhq.enterprise.communications.command.impl.remotepojo.server.RemotePojoInvocationCommandService.execute(RemotePojoInvocationCommandService.java:184)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at com.sun.jmx.mbeanserver.StandardMBeanIntrospector.invokeM2(StandardMBeanIntrospector.java:111)
	at com.sun.jmx.mbeanserver.StandardMBeanIntrospector.invokeM2(StandardMBeanIntrospector.java:45)
	at com.sun.jmx.mbeanserver.MBeanIntrospector.invokeM(MBeanIntrospector.java:226)
	at com.sun.jmx.mbeanserver.PerInterface.invoke(PerInterface.java:138)
	at com.sun.jmx.mbeanserver.MBeanSupport.invoke(MBeanSupport.java:251)
	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:857)
	at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:795)
	at javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:305)
	at $Proxy0.execute(Unknown Source)
	at org.rhq.enterprise.communications.command.server.CommandProcessor.handleIncomingInvocationRequest(CommandProcessor.java:290)
	at org.rhq.enterprise.communications.command.server.CommandProcessor.invoke(CommandProcessor.java:184)
	at org.jboss.remoting.ServerInvoker.invoke(ServerInvoker.java:967)
	at org.jboss.remoting.transport.socket.ServerThread.completeInvocation(ServerThread.java:791)
	at org.jboss.remoting.transport.socket.ServerThread.processInvocation(ServerThread.java:744)
	at org.jboss.remoting.transport.socket.ServerThread.dorun(ServerThread.java:586)
	at org.jboss.remoting.transport.socket.ServerThread.run(ServerThread.java:234)

Caused by:org.rhq.core.pluginapi.inventory.InvalidPluginConfigurationException: The original product type discovered for this AS7 server was JBoss JPP 6, but the server is now reporting its product type is [JBoss EAP 6].
	at org.rhq.modules.plugins.jbossas7.BaseServerComponent.validateServerAttributes(BaseServerComponent.java:220)
	at org.rhq.modules.plugins.jbossas7.BaseServerComponent.getAvailabilityNow(BaseServerComponent.java:154)
	at org.rhq.modules.plugins.jbossas7.BaseServerComponent.getAvailability(BaseServerComponent.java:139)
	at org.rhq.modules.plugins.jbossas7.BaseServerComponent.start(BaseServerComponent.java:101)
	at sun.reflect.GeneratedMethodAccessor37.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocation.call(ResourceContainer.java:654)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
Comment 1 Armine Hovsepyan 2013-10-02 06:50:06 EDT

*** This bug has been marked as a duplicate of bug 856845 ***
Comment 3 Thomas Segismont 2013-10-02 07:11:35 EDT
Can you please run this command in your test JPP server CLI?

[standalone@localhost:9999 /] :read-attribute(name=product-name)

The outcome should be:

{
    "outcome" => "success",
    "result" => "Portal Platform"
}

But I suspect it will be :

{
    "outcome" => "success",
    "result" => "EAP"
}

In this case, please check with JPP engineering team why.
Comment 4 Thomas Segismont 2013-10-03 06:09:18 EDT
Fixed in master

commit 02ed9c403f3ee1aa7fb1b5f1e1cee5713997fa56
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Oct 3 12:08:12 2013 +0200

Removed unused EPP entry which prevented deterministic constant look-up by product-name value
Comment 5 Simeon Pinder 2013-10-08 03:25:03 EDT
Moving to ER4 as pushed after ER3 cutoff and not beta blocker.
Comment 6 Simeon Pinder 2013-10-24 00:10:15 EDT
Moving to ON_QA for testing in the next build.
Comment 7 mgottval 2013-10-24 05:51:13 EDT
Verified with JON 3.2.ER04 + JPP 6.1.CR03.

Note You need to log in before you can comment on or make changes to this bug.