Bug 1014514 - NPE when opening BPMN process from SY editor
NPE when opening BPMN process from SY editor
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard Editor (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER6
: ---
Assigned To: Brian Fitzpatrick
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 05:20 EDT by Andrej Podhradsky
Modified: 2015-08-02 19:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1748 Major Closed NPE when opening BPMN process from SY editor 2014-06-24 07:09:40 EDT

  None (edit)
Description Andrej Podhradsky 2013-10-02 05:20:08 EDT
Description of problem:

NullPointerException is thrown when I tried to open BPMN process from SwitchYard editor. This happens only for the first time and then after restarting Eclipse/JBDS.

I also tried to open the sample.bpmn itself and it works.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Import http-bpmn.zip
2. Open SY editor
3. Double click sample process

Actual results:


Expected results:


Additional info:
Comment 1 Rob Cernich 2013-10-03 15:47:22 EDT
Hey Brian,

Can you take a look at this? See if you can get a stack trace or something.  I suspect it may be a problem in the SY extensions to the BPMN2 editor.

Thanks in advance,
Rob
Comment 2 Brian Fitzpatrick 2013-10-03 16:04:54 EDT
Yup. Looking into it now.
Comment 3 JBoss JIRA Server 2013-10-03 16:45:19 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1748

[~apodhrad] What version of the BPMN2 editor are you using?
Comment 4 JBoss JIRA Server 2013-10-03 16:50:50 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1748

It appears that there was some refactoring recently by Bob in the BPMN2 editor for https://bugs.eclipse.org/bugs/show_bug.cgi?id=416769

And that has caused all sorts of entertaining breakages in the SY BPMN2 extensions.
Comment 5 JBoss JIRA Server 2013-10-03 17:09:30 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1748

That said, the version cached with JBTIS seems to be stable (from 2013-09-19). But the version at http://download.eclipse.org/bpmn2-modeler/updates/nightly/kepler/ has the breaking changes in it from this week. 

As soon as we know what version Andrej is using we'll know more. And if the latest changes made it into JBTIS, then we have issues. 

So [~apodhrad], where'd you install the BPMN2 Modeler from? :)
Comment 6 JBoss JIRA Server 2013-10-04 02:29:47 EDT
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira SWITCHYARD-1748

I installed everything from JBTIS 4.1.3.Beta4 (JBDSIS 7.0.0.Beta4) where is

*  BPMN2 Editor 0.2.7.201309191900
*  SwitchYard	1.1.0.v20130912-2244-H393-M2
Comment 7 JBoss JIRA Server 2013-10-04 16:25:28 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1748

This PR addresses a couple of issues including some tweaks to handle a refactoring of BPMN2 Modeler code and a tweak to add types to input parameters per: https://bugs.eclipse.org/bugs/show_bug.cgi?id=418108.

It won't work to merge until Bob and Paul get a more recent version of the BPMN2 Modeler into JBTIS, but is ready to go when that happens.
Comment 8 JBoss JIRA Server 2013-10-04 16:27:23 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1748

With the latest BPMN2 Modeler and SwitchYard code loaded in a debug environment, I am unable to reproduce the issue reported in this bug. So once we have a new build that includes the refactoring on both ends we'll see if we can reproduce.
Comment 9 JBoss JIRA Server 2013-10-24 22:05:37 EDT
Rob Cernich <rcernich@redhat.com> made a comment on jira SWITCHYARD-1748

pushed
Comment 10 Andrej Podhradsky 2013-12-16 02:52:18 EST
Verified with JBDS-IS 7.0.0.CR1
Comment 11 JBoss JIRA Server 2014-06-24 07:03:29 EDT
Andrej Podhradsky <apodhrad@redhat.com> updated the status of jira SWITCHYARD-1748 to Closed

Note You need to log in before you can comment on or make changes to this bug.