Bug 1014516 - ER4-3 does not create RTGOV_SITUATION_ACTIVITY_TYPES in MySQL
ER4-3 does not create RTGOV_SITUATION_ACTIVITY_TYPES in MySQL
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER4
: 6.0.0
Assigned To: Steve Johnson
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 05:21 EDT by Jiri Pechanec
Modified: 2014-02-06 10:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Pechanec 2013-10-02 05:21:53 EDT
A startup exception
11:04:34,969 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 55) MSC000001: Failed to start service jboss.persistenceunit."overlord-rtgov-epn.war#overlord-rtgov-epn": org.jboss.msc.service.StartException in service jboss.persistenceunit."overlord-rtgov-epn.war#overlord-rtgov-epn": javax.persistence.PersistenceException: [PersistenceUnit: overlord-rtgov-epn] Unable to build EntityManagerFactory                                                                                                                                 





Caused by: javax.persistence.PersistenceException: [PersistenceUnit: overlord-rtgov-epn] Unable to build EntityManagerFactory                                                                                                                                                  







Caused by: org.hibernate.HibernateException: Missing table: RTGOV_SITUATION_ACTIVITY_TYPES                                                                                                                                                                                     






A list of tables created
mysql> show tables;
+----------------------------+
| Tables_in_soa              |
+----------------------------+
| BPAF_EVENT                 |
| BPAF_EVENT_DATA            |
| BPEL_ACTIVITY_RECOVERY     |
| BPEL_CORRELATION_SET       |
| BPEL_CORRELATOR            |
| BPEL_CORSET_PROP           |
| BPEL_EVENT                 |
| BPEL_FAULT                 |
| BPEL_MESSAGE               |
| BPEL_MESSAGE_EXCHANGE      |
| BPEL_MESSAGE_ROUTE         |
| BPEL_MEX_PROP              |
| BPEL_PARTNER_LINK          |
| BPEL_PROCESS               |
| BPEL_PROCESS_INSTANCE      |
| BPEL_SCOPE                 |
| BPEL_XML_DATA              |
| BPEL_XML_DATA_PROP         |
| GS_APP_DATA                |
| GS_GADGET                  |
| GS_GROUP                   |
| GS_PAGE                    |
| GS_USER                    |
| GS_USER_GROUP              |
| GS_WIDGET                  |
| GS_WIDGET_PREF             |
| ODE_JOB                    |
| RTGOV_ACTIVITIES           |
| RTGOV_ACTIVITY_CONTEXT     |
| RTGOV_ACTIVITY_PROPERTIES  |
| RTGOV_ACTIVITY_UNITS       |
| RTGOV_SITUATIONS           |
| RTGOV_SITUATION_CONTEXT    |
| RTGOV_SITUATION_PROPERTIES |
| STORE_DU                   |
| STORE_PROCESS              |
| STORE_PROCESS_PROP         |
| STORE_PROC_TO_PROP         |
| STORE_VERSIONS             |
| hibernate_sequence         |
+----------------------------+
40 rows in set (0.00 sec)
Comment 1 Jiri Pechanec 2013-10-02 05:49:21 EDT
An offending line from sqlresults.log

      [sql] SQL:   create table RTGOV_SITUATION_ACTIVITY_TYPES ( Situation_id varchar(255) not null, activitytypeids_collection&&element_unitid varchar(255), activitytypeids_collection&&element_unitindex integer not null )
      [sql] Failed to execute:   create table RTGOV_SITUATION_ACTIVITY_TYPES ( Situation_id varchar(255) not null, activitytypeids_collection&&element_unitid varchar(255), activitytypeids_collection&&element_unitindex integer not null )
      [sql] com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '&&element_unitid varchar(255), activitytypeids_collection&&element_unitindex int' at line 1
Comment 2 Len DiMaggio 2013-10-02 10:06:48 EDT
Safe naming strategy is backed out in Oct 2 respin - should be fixed in Oct 2 respin.
Comment 5 Jiri Pechanec 2013-10-08 03:46:55 EDT
Verified in ER4 04-Oct-2013 04:44

Note You need to log in before you can comment on or make changes to this bug.