Bug 1014531 - Remove support for IB700 watchdog
Remove support for IB700 watchdog
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
medium Severity medium
: ---
: 3.3.0
Assigned To: Martin Sivák
Lukas Svaty
sla
: Triaged
Depends On:
Blocks: 3.3snap2
  Show dependency treegraph
 
Reported: 2013-10-02 05:46 EDT by Lukas Svaty
Modified: 2016-02-10 15:19 EST (History)
10 users (show)

See Also:
Fixed In Version: is23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:14:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Engine log of start VM action (9.10 KB, text/x-log)
2013-10-02 05:47 EDT, Lukas Svaty
no flags Details
VDSM log from host of start VM action (65.96 KB, text/x-log)
2013-10-02 05:47 EDT, Lukas Svaty
no flags Details
Libvirt log of host (88.58 KB, text/x-log)
2013-10-02 05:48 EDT, Lukas Svaty
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20035 None None None Never
oVirt gerrit 20933 None None None Never

  None (edit)
Description Lukas Svaty 2013-10-02 05:46:47 EDT
Description of problem:
After start of the Vm watchdog device is removed from VM devices. This only occurs only with model ib700. The only thing in logs I found unordinary is
line 15 of engine.log:

2013-10-02 11:23:40,756 INFO  [org.ovirt.engine.core.vdsbroker.VdsUpdateRunTimeInfo] (DefaultQuartzScheduler_Worker-66) Received a watchdog Device without an address when processing VM e66c6efa-343f-4950-b0ac-cdebb7e810d6 devices, skipping device: {specParams={model=ib700, action=reset}, device=watchdog, type=watchdog, deviceId=00000000-0000-0000-0000-000000000000}

Version-Release number of selected component (if applicable):
is17
libvirt-0.10.2-27.el6.x86_64
vdsm-4.12.0-170.el6ev.x86_64
How reproducible:


Steps to Reproduce:
1. Add VM with watchdog model ib700
2. start the vm 
3. see if watchdog device still exist in api /vms/`vm-id`/watchdogs
4. see if watchdog device exist in OS

Actual results:
Watchdog device is removed from VM right after start

Additional info:
Adding engine.log vdsm.log and libvirtd.log of this action in next comment
Comment 1 Lukas Svaty 2013-10-02 05:47:31 EDT
Created attachment 806346 [details]
Engine log of start VM action
Comment 2 Lukas Svaty 2013-10-02 05:47:59 EDT
Created attachment 806347 [details]
VDSM log from host of start VM action
Comment 3 Lukas Svaty 2013-10-02 05:48:44 EDT
Created attachment 806349 [details]
Libvirt log of host
Comment 4 Lukas Svaty 2013-10-02 05:50:22 EDT
tested on VM running Red Hat Enterprise Linux Server release 6.4 Beta (Santiago)
Comment 5 Doron Fediuck 2013-10-06 09:28:11 EDT
(In reply to Lukas Svaty from comment #4)
> tested on VM running Red Hat Enterprise Linux Server release 6.4 Beta
> (Santiago)

Lukas, can you please check when the device exists is it can be seen
using lspci?

I suspect that this is not a PCI nor an IDE device, which means it has no
address assigned. Since it got no address, we will ignore it in the engine.
Comment 6 Lukas Svaty 2013-10-06 17:06:45 EDT
No this watchdog model ib700 is not in lspci as it is not a PCI device, this model is an ISA device.

This was also bug in libvirt(see BZ#637131 BZ#667091)
Comment 7 Doron Fediuck 2013-10-07 11:18:23 EDT
based on bug 667091, ib700 has no address as it is not a PCI device.
The resolution is to remove support in ib700.
Comment 8 Lukas Svaty 2013-10-08 06:04:09 EDT
this also may need edit for ui (no need for user to choose between only one supported model (i6300esb)
Comment 9 Martin Sivák 2013-10-09 10:02:04 EDT
You can still choose between no watchdog device and i6300esb.
Comment 10 Lukas Svaty 2013-10-09 10:11:25 EDT
than some checkbox would be more suitable or changing the blank option to something like `no watchdog card`
Comment 12 Lukas Svaty 2013-11-15 06:46:52 EST
tested in is23
Comment 13 Itamar Heim 2014-01-21 17:14:06 EST
Closing - RHEV 3.3 Released
Comment 14 Itamar Heim 2014-01-21 17:21:55 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.