Bug 1014548 - Update firewalld to Python 3
Update firewalld to Python 3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On: 1014584 1023985
Blocks: PY3ANACONDA
  Show dependency treegraph
 
Reported: 2013-10-02 06:37 EDT by Miro Hrončok
Modified: 2013-11-12 21:13 EST (History)
3 users (show)

See Also:
Fixed In Version: firewalld-0.3.8-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:33:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miro Hrončok 2013-10-02 06:37:16 EDT
Congratulations! Your package has been chosen as a MUST to be updated to Python 3 :)

The goal here is, that this package uses Python 3 as default.

And how to do it? Follows those easy steps:

1. Check if upstream already support Python 3, if yes, use it
2. If upstream doesn't support Python 3 yet, encourage it to do so by sending patches and offering your help, then go to 1.

If you end up in infinite loop, there's something broken. I.e. upstream is dead or unwilling to support Python 3. In that case, you'll need to patch this package on Fedora level. Try to avoid this as much as you can, but use it, if it's the last option.

Chances are, that you ARE the upstream. In that case, everything is easier, just do it yourself.

Once Python 3 is supported, check your package, if it works with it. If you don't want to switch to Python 3 yet as a default (that's still against guidelines), I recommend to prepare your spec and conditionalize the thing with something like %global default_python 2.

There is a table on wiki, that should list your package. Chances are, that you can see an upstream link that covers the problem. Anyway, please update the table with information you know.

https://fedoraproject.org/wiki/User:Churchyard/python3

And, of course, if you need help, that's why I am here :)

(As you've already realized, this is a bulk text, so if something is not quite exact about your package, sorry for that, just ask)
Comment 1 Miro Hrončok 2013-10-02 06:39:55 EDT
And I forgot to say, the goal is for Fedora 22.
Comment 2 Toshio Ernie Kuratomi 2013-10-02 18:15:59 EDT
Note: do not follow this piece of advice as it is against the Packaging Guidelines: "When upstream is dead or unwilling to support Python 3, you'll need to patch this package on Fedora level. Try to avoid this as much as you can, but use it, if it's the last option."

If you are in this situation, you'll essentially be forking upstream in order to produce a python3 port.  In that situation, the proper thing to do is to create a new package with the python3 port.  It would be even better to create the proper upstream infrastructure as well (new upstream scm and issue tracker) but that isn't 100% required by the guidelines.
Comment 3 Thomas Woerner 2013-10-28 10:38:45 EDT
firewalld is 100% python3 compatible since last week.

There is a bug in the python3 dbus bindings though: #1023985

With this bug the memory usage of firewalld is growing and there are lots of objects marked as garbage.
Comment 4 Fedora Update System 2013-11-05 10:39:59 EST
firewalld-0.3.8-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/firewalld-0.3.8-1.fc20
Comment 5 Fedora Update System 2013-11-05 10:40:59 EST
firewalld-0.3.8-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/firewalld-0.3.8-1.fc19
Comment 6 Fedora Update System 2013-11-05 14:59:35 EST
Package firewalld-0.3.8-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.3.8-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20696/firewalld-0.3.8-1.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-11-10 01:33:57 EST
firewalld-0.3.8-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-11-12 21:13:04 EST
firewalld-0.3.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.