Bug 1014577 - python-paste: Support Python 3
python-paste: Support Python 3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-paste (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F23PYTHON3
  Show dependency treegraph
 
Reported: 2013-10-02 07:10 EDT by Miro Hrončok
Modified: 2015-11-13 12:15 EST (History)
5 users (show)

See Also:
Fixed In Version: python-paste-2.0.2-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 12:15:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miro Hrončok 2013-10-02 07:10:07 EDT
Hi, we would like to use Python 3 on the default installation instead of Python 2 on Fedora 22.

From that perspective, your package is considered as IMPORTANT - that means, is has to be updated to Python 3, for our intention come true.

The goal here is, that at least for F22 you should provide python3- prefixed subpackage.

Please, help use update to Python 3 flawlessly.

Check if upstream already support Python 3, if yes, use it and add te support to the package.

If upstream doesn't support Python 3 yet, encourage it to do so by sending patches and offering your help.

When upstream is dead or unwilling to support Python 3, you'll need to patch this package on Fedora level. Try to avoid this as much as you can, but use it, if it's the last option.

Chances are, that you ARE the upstream. In that case, everything is easier, just do it yourself.

There is a table on wiki, that should list your package. Chances are, that you can see an upstream link that covers the problem. Anyway, please update the table with information you know.

https://fedoraproject.org/wiki/User:Churchyard/python3

I offer my help with this task, so if you have no idea, how to work on this, or it is just not your priority, don't hesitate to ask for help.

(As you've already realized, this is a bulk text, so if something is not quite exact about your package, sorry for that, just ask)
Comment 1 Toshio Ernie Kuratomi 2013-10-02 18:32:13 EDT
Note: do not follow this portion of the advice as it is against the Packaging Guidelines: "When upstream is dead or unwilling to support Python 3, you'll need to patch this package on Fedora level. Try to avoid this as much as you can, but use it, if it's the last option."

If you are in this situation, you'll essentially be forking upstream in order to produce a python3 port.  In that situation, the proper thing to do is to create a new package with the python3 port.  It would be even better to create the proper upstream infrastructure as well (new upstream scm and issue tracker) but that isn't 100% required by the guidelines.
Comment 2 Toshio Ernie Kuratomi 2013-10-02 18:36:45 EDT
There's no upstream support for python3 and paste and from what I hear there isn't going to be any (pyramid/TG2 devs might work on something but they have yet to release a fork).  paste is also wsgi implementing code (rather than wsgi consuming code) so it's a very tough thing to provide a unified code-base port of (the wsgi specification for python2 and python3 is different).  If paste is ported, it's probably going to need to be in a different package because it won't be a single upstream tarball for python2 and python3.

It's probably best to port to a different library that provides something similar rather than trying to port paste itself anyway.  Will note this advice on the User:Churchyard/python3 wiki page and closing this bug as CANTFIX.
Comment 3 Luke Macken 2013-10-03 21:11:53 EDT
Both Pyramid and TurboGears have forked parts of Paste and ported them to Python3.

https://github.com/TurboGears/gearbox
https://github.com/Pylons/pyramid/tree/master/pyramid/scripts
Comment 4 Miro Hrončok 2014-05-30 08:10:46 EDT
I got an impression that upstream supports Python 3 now. See https://bitbucket.org/ianb/paste/commits/all
Comment 5 Jaroslav Reznik 2015-03-03 10:07:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 6 Robert Kuska 2015-06-02 04:06:09 EDT
Would it be possible to update paste? There is 2.0.2 [1] version already on pypi which should support python3.


[1] https://pypi.python.org/packages/source/P/Paste/Paste-2.0.2.tar.gz#md5=4bfc8a7eaf858f6309d2ac0f40fc951c
Comment 7 Nils Philippsen 2015-08-14 10:33:14 EDT
Luke, would you mind if I gave it a shot?
Comment 8 Nils Philippsen 2015-08-14 11:48:32 EDT
as discussed on #fedora-releng
Comment 9 Robert Kuska 2015-09-07 02:29:55 EDT
Any update?
Comment 10 Nils Philippsen 2015-09-09 05:17:03 EDT
I'm working on it ;). I've made a few patches on top of upstream git master, see here:

https://github.com/nphilipp/paste/commits/py3k
Comment 11 Nils Philippsen 2015-11-13 10:53:55 EST
Tests are good now, opened an issue for upstream on bitbucket: https://bitbucket.org/ianb/paste/issues/13/tests-failing-under-python-3

Note You need to log in before you can comment on or make changes to this bug.