Bug 1014582 - Uncaught execption when selecting time range on graph image
Uncaught execption when selecting time range on graph image
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: ER07
: JON 3.2.0
Assigned To: Mike Thompson
Mike Foley
:
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-02 07:14 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-10-02 07:14:48 EDT
Description of problem: I am getting uncaught exception when I select time range of specified metric


Version-Release number of selected component (if applicable):
JON 3.2.ER2

How reproducible:always


Steps to Reproduce:
1.have metric graph image with some data
2. select some time range from graph

Actual results: you get uncought exception: 

(TypeError) stack: isc_FormItem_getValue@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js:1370 isc_FormItem_updateValueMap@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js:1273 isc_FormItem_setValueMap@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js:1270 isc_c_Class_invokeSuper@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:284 isc_c_Class_Super@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:276 isc_SelectItem_setValueMap@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js:2366 $setValueMapMethod@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:5210 $setValueMap@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:5201 setValueMap@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:5368 $onSuccess_432@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:109435 onSuccess_445@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:109450 $onResponseReceived@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:5545 onResponseReceived_6@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:42968 $fireOnResponseReceived@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:1435 onReadyStateChange_0@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:1686 $setOnReadyStateChange/this$static.onreadystatechange<@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:6372 apply@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:527 entry0@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:565 entry_0/<@http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/6321CFB80197047E7AF8EB6F373C81CC.cache.html:550 fileName: http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js lineNumber: 1370 columnNumber: 0: this.form is null
Detail :	

com.google.gwt.core.client.JavaScriptException:(TypeError) 


Expected results:


Additional info:
Comment 1 Mike Thompson 2013-10-02 11:14:30 EDT
I'm not seeing this in master. I believe this is the same issue as BZ 1012431.

Please reconfirm in ER03.
Comment 2 Simeon Pinder 2013-11-06 21:18:15 EST
Moving to ON_QA for test with new brew build.
Comment 3 Libor Zoubek 2013-11-07 06:25:06 EST
Hi Mike, 

I can still reproduce it on ER5, currently cannot check on RHQ master, since there is an install issue.

Maybe this helps:

fileName: http://lzoubek1.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/org.rhq.coregui.CoreGUI/sc/modules/ISC_Forms.js
 lineNumber: 1289
 columnNumber: 86: this.form is null
   at Unknown.isc_FormItem_getValueFieldName(Unknown Source)
   at Unknown.isc_FormItem_getDisplayFieldName(Unknown Source)
   at Unknown.isc_SelectItem__mapKey(Unknown Source)
   at Unknown.isc_FormItem_mapValueToDisplay(Unknown Source)
   at Unknown.isc_c_Class_invokeSuper(Unknown Source)
   at Unknown.isc_SelectItem_mapValueToDisplay(Unknown Source)
   at Unknown.isc_FormItem_updateValueMap(Unknown Source)
   at Unknown.isc_FormItem_setValueMap(Unknown Source)
   at Unknown.isc_c_Class_invokeSuper(Unknown Source)
Comment 4 Mike Thompson 2013-11-07 16:24:06 EST
I was selecting the time range from the time range buttons and didn't realize step 2 meant do a drag selection. I see the issue.
Comment 5 Mike Thompson 2013-11-12 14:26:24 EST
Added a dragSelectionRefresh handler to allow more specific handling of drag selection refreshes versus regular refreshes. Externalized some of the ButonBarDateTimeRangeEditor state to consolidate state across the many instances (single, multiple, graph/non-graph) of the ButtonBarDateTimeRangeEditor and allow access to that state without having an explicit reference.
Comment 6 Heiko W. Rupp 2013-11-14 03:37:46 EST
Seems like master 1a90ed881043f
Comment 7 Mike Thompson 2013-11-14 09:46:28 EST
Two commits to master. The first commit addresses the root problem and the second fixes a bug that at first looked like it was caused by this fix. In fact, it was broken a couple weeks ago by the Live Values fix. The second commit fixes the 'Add to Dashboard' functionality, which I uncovered while testing this bug.


First commit to master: a7fee7a
Second commit to master: 1a90ed8
Comment 8 Mike Thompson 2013-11-14 15:47:50 EST
I created a second BZ 1030497 for the 'Add to Dashboard' fix as it was a separate issue. [It has also been pushed to release/jon3.2.x]

Pushed commit to release/jon3.2.x: 663598b
Comment 9 Mike Thompson 2013-11-14 22:31:24 EST
Found a bug with a particular path that caused the metrics grid to become empty.
Steps to reproduce:
1) Click on CPU 0 resource in tree
2) Click on File Systems group in tree
3) Click on Summary Tab
4) Click on CPU 0 in tree
5) Click on Monitoring tab

At this point the metrics grid becomes empty [it should be populated].

This is Fixed and...

Committed to master: 4c48a1d
Committed to release/jon3.2.x: 55ebe37
Comment 10 Simeon Pinder 2013-11-19 10:48:51 EST
Moving to ON_QA as available for testing with new brew build.
Comment 11 Simeon Pinder 2013-11-22 00:14:16 EST
Mass moving all of these from ER6 to target milestone ER07 since the ER6 build was bad and QE was halted for the same reason.
Comment 12 Libor Zoubek 2013-11-25 03:57:13 EST
verified on ER7

Note You need to log in before you can comment on or make changes to this bug.