Bug 1014594 - sssd: Support Python 3
sssd: Support Python 3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F23PYTHON3 F22AlphaFreezeException
  Show dependency treegraph
 
Reported: 2013-10-02 07:25 EDT by Miro Hrončok
Modified: 2015-03-02 23:19 EST (History)
10 users (show)

See Also:
Fixed In Version: sssd-1.12.4-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-02 23:19:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FedoraHosted SSSD 2017 None None None Never

  None (edit)
Description Miro Hrončok 2013-10-02 07:25:41 EDT
Hi, we would like to use Python 3 on the default installation instead of Python 2 on Fedora 22.

From that perspective, your package is considered as IMPORTANT - that means, is has to be updated to Python 3, for our intention come true.

The goal here is, that at least for F22 you should provide python3- prefixed subpackage.

Please, help use update to Python 3 flawlessly.

Check if upstream already support Python 3, if yes, use it and add te support to the package.

If upstream doesn't support Python 3 yet, encourage it to do so by sending patches and offering your help.

When upstream is dead or unwilling to support Python 3, you'll need to patch this package on Fedora level. Try to avoid this as much as you can, but use it, if it's the last option.

Chances are, that you ARE the upstream. In that case, everything is easier, just do it yourself.

There is a table on wiki, that should list your package. Chances are, that you can see an upstream link that covers the problem. Anyway, please update the table with information you know.

https://fedoraproject.org/wiki/User:Churchyard/python3

I offer my help with this task, so if you have no idea, how to work on this, or it is just not your priority, don't hesitate to ask for help.

(As you've already realized, this is a bulk text, so if something is not quite exact about your package, sorry for that, just ask)
Comment 1 Jakub Hrozek 2013-10-02 08:01:27 EDT
Hi, we already have an upstream ticket for converting to Python 3. However, it's not the biggest priority for us. If you have time, any help would be mostly welcome. I can show you the way around the code and help you with submitting a patch.
Comment 2 Jakub Hrozek 2013-10-02 08:13:59 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2017
Comment 3 Toshio Ernie Kuratomi 2013-10-02 18:43:05 EDT
Noting here for people who might read this out of context via a web search (since this will be fixed via upstream code changes it shouldn't apply here):

Note: do not follow this portion of the advice as it is against the Packaging Guidelines: "When upstream is dead or unwilling to support Python 3, you'll need to patch this package on Fedora level. Try to avoid this as much as you can, but use it, if it's the last option."

If you are in this situation, you'll essentially be forking upstream in order to produce a python3 port.  In that situation, the proper thing to do is to create a new package with the python3 port.  It would be even better to create the proper upstream infrastructure as well (new upstream scm and issue tracker) but that isn't 100% required by the guidelines.
Comment 4 Jakub Hrozek 2015-01-13 04:29:09 EST
* master: 341a00311680a440d7f979f06c34c70d86c9367a
Comment 5 Fedora Blocker Bugs Application 2015-02-24 10:37:49 EST
Proposed as a Freeze Exception for 22-alpha by Fedora user sgallagh using the blocker tracking app because:

 The patches for Python 3 support are almost ready, but were slightly late for Alpha Freeze. We would still like to land these in Alpha so they have sufficient time to bake.
Comment 6 Jakub Hrozek 2015-02-25 02:44:03 EST
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2574
Comment 7 Jakub Hrozek 2015-02-25 03:05:51 EST
parallel-build patches were pushed to master:
* 889706cbc739358c2a0aac2ba6bc054fdc8e048b
* b6840554b4eeda395f5460a56df2eac1f3f97397
* 18372712592b30638772afb5b7e15bfca92c2058
* 4a5a18f489f4d19aa0571528a7f0c7a8d35ac83f
* 4706958e7505ce279f06cb2bf413eb38ee8f114c
* de0b510a1919b3952e983babf5b37ac499233a2a
* dc4c30bae512c0b45ff925d9e998337f8fe97e94
* e4796d5ed8e08be7f3767e12753389b18a2ce9f0
* 03e9d9d6c1d8768a6f70217bababd82de29bc770
* a63b368a025a61edf41a3d5ce34f325b03295cf6
* 887edd6b7c53fde44eb9f9060e09db5cd981ba37
* 9eabaad5e0f3f20a6bcec0629342584c244a79bc
* d6c3de740c7bed8b007805d6a313220d8d974ee5
* 36458f3054020f046c4a9b81d0112c7ca2e1be1c
* 4e0404ca1b19830dc0f729e59efd5bbd0a9d6103
Comment 8 Fedora Update System 2015-02-25 09:15:04 EST
sssd-1.12.4-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/sssd-1.12.4-2.fc22
Comment 9 Fedora Update System 2015-02-25 10:15:23 EST
Package sssd-1.12.4-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sssd-1.12.4-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2552/sssd-1.12.4-2.fc22
then log in and leave karma (feedback).
Comment 10 Petr Schindler 2015-03-02 15:52:44 EST
Discussed at today's blocker review meeting [1].

This bug was accepted as Freeze Exception - This bug has been granted FE status. Please apply the patch so it can be tested with the next compose.

http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-02/
Comment 12 Fedora Update System 2015-03-02 23:19:59 EST
sssd-1.12.4-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.