Bug 10146 - Apache startup fails, if mod_perl is active
Summary: Apache startup fails, if mod_perl is active
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mod_perl (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: sparc Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-13 15:51 UTC by Roland Hebertinger
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-16 20:05:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roland Hebertinger 2000-03-13 15:51:59 UTC
When mod_perl is activated in the httpd.cond, apache fails to start up.
/var/log/messages just states "httpd startup failed". There are no further
messages in other logfiles. Even in debug mode that's all apache writes to
the logfiles.
Without mod_perl, apache starts up just fine.
Reinstalling mod_perl and apache could not solve the problem...

The machine we're running RedHat Linux on is a SUN SparcStation 5-85 with
64 MB RAM. We use the standard packages from the distribution (mod_perl
1.21-2, apache 1.3.9-4). Further non-standard modules we use are mod_php
and mod_php3, but even when we use an apache configuration without these
modules, it won't start...

Comment 1 Nalin Dahyabhai 2000-03-14 14:58:59 UTC
Try running "/usr/sbin/httpd -t" to do a quick syntax check of your
configuration file, and use "rpm --verify mod_perl".  If everything
checks out, try grabbing the versions of apache and mod_perl from Raw
Hide (ftp://ftp.redhat.com/pub/rawhide/sparc/RedHat/RPMS/), which are
known to work.  Please let me know if this solves the problem.

Comment 2 Roland Hebertinger 2000-03-15 08:20:59 UTC
"/usr/sbin/httpd -t" crashed with a seg fault, rpm --verify mod_perl worked
without errors.
The updated rpms from Raw Hide solved the problem. Now apache starts up with
mod_perl active and perl skripts run just fine!

Comment 3 Nalin Dahyabhai 2000-03-15 16:52:59 UTC
Glad to hear it.  Did you want to pursue the cause of the crash, or
should I close out this bug and flag it as resolved in Raw Hide?

Comment 4 Roland Hebertinger 2000-03-16 18:32:59 UTC
You can close the bug. At the moment I don't have time to do any further work on
this...


Note You need to log in before you can comment on or make changes to this bug.