Bug 1014603 - Help: Link : fix the help links in the application so they don't lead to invalid places
Help: Link : fix the help links in the application so they don't lead to inva...
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation, UI (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: ER05
: JON 3.2.0
Assigned To: Deon Ballard
Mike Foley
:
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-02 07:35 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 10:50:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-10-02 07:35:12 EDT
Description of problem: Help: Link : How to use "Bundles and application provisioning" leads to invalid place


Version-Release number of selected component (if applicable):
JON 3.2.ER2


Actual results:Red Hat customer portal returns "NOT FOUND" page

Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information:
Comment 1 Heiko W. Rupp 2013-10-28 11:06:32 EDT
Libor, can you paste the failing link please?
Comment 2 Heiko W. Rupp 2013-10-28 11:57:20 EDT
This seems to be the bogus link:

https://access.redhat.com/site/documentation/en-US/JBoss_Operations_Network/3.1/html/Admin_Deploying_Applications_and_Content/provisioning-apps.html

While we need to change all links to point to 3.2 docs, this also means we need to have a redirect for 3.1.2 in place
Comment 4 John Mazzitelli 2013-10-28 16:47:08 EDT
update this file with the new urls: <jon-git-home>/jon/dist/server/src/main/scripts/dist.build.xml
Comment 5 John Mazzitelli 2013-10-28 19:30:44 EDT
there is a git commit to the upstream master that goes along with this - it fixes the help icons next to the links - master: 0ba38a7 , release/jon3.2.x: 9d404bc
Comment 7 John Mazzitelli 2013-10-29 11:09:36 EDT
commit to jon repo release/jon3.2.x branch: 7b724af

this fixes all the help links so they point to the 3.2 location - also adds new help links.

do NOT test this until the doc team publishes the 3.2 documentation
Comment 8 John Mazzitelli 2013-10-29 11:50:59 EDT
fix the help link in the about box so it points to the redhat product page
jon repo, release/jon3.2.x commit: cdd773d
Comment 9 John Mazzitelli 2013-10-29 11:54:33 EDT
fix type: commit d0ce856
Comment 10 Simeon Pinder 2013-11-06 21:17:48 EST
Moving to ON_QA for test with new brew build.
Comment 11 Sunil Kondkar 2013-11-07 08:22:43 EST
Tested on Version : 3.2.0.ER5 Build Number : 2cb2bc9:225c796

The help links in 'Documentation' and 'Tutorial' section are showing 'Not Found'. ( Except the link for 'Documenation Set' which is working.)
Comment 12 Deon Ballard 2013-11-07 10:50:29 EST
This is not a bug. As mazz said in comment 7, none of the JON 3.2 documentation is live, because JON 3.2 has not been released. So, none of the links will work (except Documentation Set, which goes to the JON docs landing page).

I am going to close this bug. If any link doesn't work *post-GA*, that's a bug.

Note You need to log in before you can comment on or make changes to this bug.