This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1014622 - Ignored resources show up in "Suspect metrics" report
Ignored resources show up in "Suspect metrics" report
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Inventory (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity high
: DR02
: JON 3.2.1
Assigned To: John Mazzitelli
Mike Foley
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 08:21 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-08 13:43:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-10-02 08:21:39 EDT
Description of problem:
My use case is: I look at suspect metrics, and I realize, I don't care about some metric values, but I am too lazy to disable that particular metric and I don't care about that resource at all, so I ignore it.

Ignored resources are showing up in "Suspect metrics" report

Version-Release number of selected component (if applicable):
JON 3.2.ER2

How reproducible: always


Steps to Reproduce:
1. look at "Suspect metrics" report, find any resource
2. Ingore it
3. go back to "Suspect metrics"

Actual results: ignored resource is still there, 'tough if you try to navigate on it, JON shows it as non-existing resource


Expected results: I should see no reference to igonred resource (except for "Ignored resoruces" where I can unignore it)


Additional info:
Comment 1 Simeon Pinder 2013-11-08 09:41:14 EST
Moving to unspecified target milestone as only JON 3.2.0 'blockers'(https://url.corp.redhat.com/bz-jon32-blockers-list-notmodified-nodocs) will make it into subsequent builds after ER5.
Comment 2 John Mazzitelli 2013-12-03 16:40:12 EST
this shouldn't go in 3.2 since we are in code freeze. Moving to 3.2.1 target version.

checked into master: c954eda
Comment 5 Jay Shaughnessy 2014-02-18 10:37:44 EST
release/jon3.2.x commit 11d7a43e94eae53fa4267a2434a3bf39a68980cf
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Tue Feb 18 10:36:20 2014 -0500
    
    Cherry-Pick of master c954eda
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>
Comment 6 Simeon Pinder 2014-03-05 17:21:26 EST
Moving to ON_QA as available for testing in the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=340294

Note: the installed version is still JON 3.2.0.GA by design and this represents part of the payload for JON 3.2.1 also known as cumulative patch 1 for 3.2.0.GA.  How this will be delivered to customers is still being discussed.
Comment 7 Mike Foley 2014-03-06 12:09:26 EST
Verified JON 3.2.1 DR2
Comment 8 Mike Foley 2014-05-08 13:43:43 EDT
JON 3.2.1 released week of 5/5/2014

Note You need to log in before you can comment on or make changes to this bug.