Bug 101463 - User Manager is not reading current values from system, and over-writing them with defaults
Summary: User Manager is not reading current values from system, and over-writing them...
Status: CLOSED DUPLICATE of bug 88190
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-users   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 101028
TreeView+ depends on / blocked
 
Reported: 2003-08-01 15:07 UTC by Mark Post
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Post 2003-08-01 15:07:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
When I added several users to the system, these entries were created in /etc/shadow:
user1:$password1:12264:0:99999:7:::
user2:$password2:12264:0:99999:7:::

If I then go into user manager a second time, select "properties" for a user,
and then click "OK" instead of "Cancel" to exit, these values get entered into
/etc/shadow:

user1:$password1:12264:0:0:7:0::
user2:$password2:12264:0:99999:7:::

Note that I did _not_ change anything, I just displayed the user properties, and
then clicked on "OK" to exit.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Add a user via User Manager
2.cat /etc/shadow
3.Select that user, and click on the Properties icon
4.Click "OK" to exit the properties display
5.cat /etc/shadow
    

Actual Results:  The data that was in /etc/shadow for the user I displayed was
modified.

Expected Results:  The data should have remained unchanged.

Additional info:

Comment 1 Brent Fox 2003-10-14 01:08:11 UTC
This is a dupe of bug #88190.  

*** This bug has been marked as a duplicate of 88190 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:57:55 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.