Bug 1014631 - IllegalStateException in agent.log during rhqctl stop/start
IllegalStateException in agent.log during rhqctl stop/start
Status: CLOSED WORKSFORME
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.2
x86_64 Linux
unspecified Severity medium
: ---
: JON 3.3.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 08:42 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-26 11:31:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2013-10-02 08:42:05 EDT
Description of problem:
IllegalStateException in agent.log during rhqctl stop/start 

Version-Release number of selected component (if applicable):
jon 3.2 er2

How reproducible:
always

Steps to Reproduce:
1. install jon server, agent and storage on the same box and start them
2. run rhqctl stop 
3. run rhqctl start

Actual results:
IllegalStateException in agent.log after each stop/start

Expected results:
no exceptions in agent log, agent starts smoothly after being stopped

Additional info:
fragment from agent.log -> http://pastebin.test.redhat.com/167592
Comment 1 Simeon Pinder 2013-11-08 09:41:17 EST
Moving to unspecified target milestone as only JON 3.2.0 'blockers'(https://url.corp.redhat.com/bz-jon32-blockers-list-notmodified-nodocs) will make it into subsequent builds after ER5.
Comment 4 Jay Shaughnessy 2014-08-26 11:31:27 EDT
pastebin clip is gone. I could not reproduce in 3.3 (windows) but in general I suppose it's possible a shutdown could find a way to generate an exception.  Closing as works for me and since it seems to have no ill affect on the agent.

Note You need to log in before you can comment on or make changes to this bug.