Bug 1014673 - Assigning repo to content view definition in UI clears the puppet repo selection
Assigning repo to content view definition in UI clears the puppet repo selection
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: David Davis
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 10:05 EDT by Ivan Necas
Modified: 2014-04-24 13:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Necas 2013-10-02 10:05:39 EDT
Steps to Reproduce:
1. create yum and puppet repo
2. create content view definition, add the puppet repo to it
3. add the yum repo to the definition
4. reload the page

Actual results:
the puppet repo is not selected in the definition

Expected results:
the puppet repo keeps selected after adding the yum repo
Comment 2 David Davis 2013-10-07 16:24:50 EDT
https://github.com/Katello/katello/pull/3111
Comment 3 David Davis 2013-10-09 08:48:24 EDT
katello f3997174e38e1a9639a2cb1b0398902f10ded4b0

1014673: Fix problem where puppet repo gets unset
Comment 6 Sachin Ghai 2013-10-21 04:54:22 EDT
Bz 1021394 needs to be fixed to verify this bz.
Comment 7 Sachin Ghai 2013-10-22 07:03:33 EDT
Bz 1021394 is fixed  which is duplicate of 1020463. So I re-verified it with following build:
 
[root@HOST201-143 ~]# rpm -qa | grep katello
katello-1.4.6-44.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-configure-1.4.7-7.el6sat.noarch
katello-glue-elasticsearch-1.4.6-44.el6sat.noarch
katello-foreman-all-1.4.6-44.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-44.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
katello-cli-1.4.3-26.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-glue-pulp-1.4.6-44.el6sat.noarch
katello-glue-candlepin-1.4.6-44.el6sat.noarch
katello-cli-common-1.4.3-26.el6sat.noarch
katello-all-1.4.6-44.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch

After adding the puppet repo and then yum repo to cv, when we reload the page, the puppet repo keeps selected. Please see the screenshot for verification.
Comment 8 Bryan Kearney 2014-04-24 13:10:47 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 9 Bryan Kearney 2014-04-24 13:11:53 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.