Bug 1014678 - Add link to JNDI names reference [NEEDINFO]
Add link to JNDI names reference
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: EAP 6.3.0
Assigned To: sgilda
Russell Dickenson
: Documentation, EasyFix, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 10:15 EDT by Jan Martiska
Modified: 2014-08-14 11:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14875, Development Guide-6.2-1 Build Date: 02-10-2013 13:20:00 Topic ID: 5719-459903 [Latest]
Last Closed: 2014-08-06 10:39:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgilda: needinfo? (rdickens)


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2013-10-02 10:15:59 EDT
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html/Development_Guide/sect-Invoking_Session_Beans.html#Invoke_a_Session_Bean_Remotely_using_JNDI

Procedure 7.8. Obtain a Bean Proxy using JNDI and Invoke Methods of the Bean

At the end of step 3, there is the note 'Session bean JNDI names are defined using a special syntax.' I think it would be useful to add a link to the reference documentation for this syntax. It is here: http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html/Development_Guide/sect-Reference-2.html
Comment 1 sgilda 2013-11-06 10:49:40 EST
Darrin, I will take this one since I made other fixes to it.

Topic 5719 "Invoke a Session Bean Remotely Using JNDI" topic is included in multiple guides:

These have revisions, so I don't believe they are impacted:

14875, Development Guide, JBoss Enterprise Application Platform, 6.2 (beta?)
14877, Migration Guide, JBoss Enterprise Application Platform, 6.2 (Beta?)

I am not clear what this one is for or if it is used:

11637, Migration Guide , JBoss Portal Platform, 6 (Is this even used?)

These seem to be the current guides:

22509, Development Guide, JBoss Enterprise Application Platform, 6.2
22507, Migration Guide, JBoss Enterprise Application Platform, 6.2

The Development Guide content spec contains topic 5119 "EJB JNDI Naming Reference": 
    EJB JNDI Naming Reference [5119, rev: 459907]

None of the Migration Guide content specs contain this topic. I need to check with Russell to make sure I can change the content specs for 11637 and 22507 before I can change this topic.
Comment 2 sgilda 2013-11-06 11:01:47 EST
Russell, is it too late to update the maps? 

Is map 11637 even valid?
Comment 3 sgilda 2014-02-24 15:07:25 EST
Modified topic 5719 to refer to topic 4119:
Invoke a Session Bean Remotely using JNDI [5719, rev: 593715]

Modified content spec 22507 for the Migration Guide for 6.3: 22507

    Section: Remote Invocation Changes
      Migrate JBoss EAP 5 Deployed Applications That Make Remote Invocations to JBoss EAP 6 [4943]
      Invoke a Session Bean Remotely using JNDI [5719]
      EJB JNDI Naming Reference [5119]

I am rebuilding the Migration Guide for 6.2 for other issues, so I will modify the map 14877 for the 6.2 Migration Guide.
Comment 4 Scott Mumford 2014-02-26 00:13:04 EST
Moving to ON_QA.

The changes should be available for review on the documentation stage within an hour or so from this comment.

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/
Comment 5 Scott Mumford 2014-02-26 00:15:25 EST
Moving to ON_QA.

The changes should be available for review on the documentation stage within an hour or so from this comment.

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/
Comment 6 Jan Martiska 2014-02-26 04:48:35 EST
Verified, thanks.

Note You need to log in before you can comment on or make changes to this bug.