Bug 1014696 - optimize scheduling for speed
optimize scheduling for speed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Gilad Chaplik
Artyom
sla
:
Depends On:
Blocks: 1019461 3.3rc1
  Show dependency treegraph
 
Reported: 2013-10-02 10:42 EDT by Gilad Chaplik
Modified: 2016-02-10 15:13 EST (History)
8 users (show)

See Also:
Fixed In Version: is27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19270 None None None Never
oVirt gerrit 22173 None None None Never

  None (edit)
Description Gilad Chaplik 2013-10-02 10:42:26 EDT
Since scheduling process is synchronized, and can be costly when there are numerous concurrent pending requests, add to the cluster an 'optimize for speed' (vs utilization) ability, that should be able to skip weighing process in case there are more than X requests pending to be scheduled, and let the load balancing process to balance the cluster in a lazy manner.
Comment 1 Artyom 2013-12-12 08:15:33 EST
Please provide information for reproducing process.
Thanks
Comment 2 Gilad Chaplik 2013-12-12 08:34:00 EST
(In reply to Artyom from comment #1)
> Please provide information for reproducing process.
> Thanks

Added a cluster configuration (optimize for speed) that allows to skip scheduling weights, in-case there are more than X request pending on the scheduler (X =	config.SpeedOptimizationSchedulingThreshold). this was added to shorter scheduling processes on a loaded environment. No weights means that one of the host (and not the preferable) will be selected for scheduling, and the load balancer should balance the cluster later on.

To test it, I'd reduce the threadhold to a lower number, and have an external module that takes time (sleep can do the trick). Then run several run vm commands  (in parallel)from the REST API. The scheduling request should pile up, and when there are X (threshold) pending, the weight part will be skipped.
Comment 3 Artyom 2013-12-16 12:48:51 EST
Verified is27
Comment 4 Itamar Heim 2014-01-21 17:23:32 EST
Closing - RHEV 3.3 Released
Comment 5 Itamar Heim 2014-01-21 17:24:36 EST
Closing - RHEV 3.3 Released
Comment 6 Itamar Heim 2014-01-21 17:28:15 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.