Bug 1014735 - packstack: default_store in glance-api.conf changes from swift to file when you re-run packstack
packstack: default_store in glance-api.conf changes from swift to file when y...
Status: CLOSED DUPLICATE of bug 1012382
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
x86_64 Linux
unspecified Severity high
: ---
: 4.0
Assigned To: Martin Magr
Nir Magnezi
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 11:59 EDT by Dafna Ron
Modified: 2013-11-15 07:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 07:21:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
packstack installtion log (1.51 KB, application/x-xz)
2013-10-02 11:59 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1234261 None None None Never

  None (edit)
Description Dafna Ron 2013-10-02 11:59:49 EDT
Created attachment 806551 [details]
packstack installtion log

Description of problem:

I have swift configured as glance backend.
when I run packstack again to make changes it changes the field default_store in glance-api.conf back to file and than the images I create are created locally instead of in swift storage servers.
the change I was trying to do is add more zones, replication and storage servers for swift.

Version-Release number of selected component (if applicable):

openstack-packstack-2013.2.1-0.5.dev740.el6ost.noarch
openstack-glance-2013.2-0.10.b3.el6ost.noarch
openstack-swift-1.8.0-6.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:

1. install swift as an object server using packstack - give it 1 zone, 1 replication and 2 storage servers
2. configure swift as glance default_store.
3. change the fields in the answer file for swift to add more storage servers, more zones and more replication and re-run packstack

Actual results:

packstack is changing default_store value in glance-api.conf to file which means the images will be saved locally instead in swift (rendering the swift as backend mute) 

Expected results:

we should not touch the default_store value in glance-api.conf

Additional info:

Please note that there is another problem in which we fail to expend swift using packstack so the install log I am adding is actually a failure log. 
but the default_store has changed even with the failure.
Comment 2 Alvaro Lopez Ortega 2013-11-15 07:21:56 EST

*** This bug has been marked as a duplicate of bug 1012382 ***

Note You need to log in before you can comment on or make changes to this bug.