Bug 1014737 - Memtest86+ new upstream version 5.01 available
Memtest86+ new upstream version 5.01 available
Status: CLOSED DUPLICATE of bug 1013110
Product: Fedora
Classification: Fedora
Component: memtest86+ (Show other bugs)
20
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 12:07 EDT by c72578
Modified: 2013-12-06 09:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-06 09:20:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description c72578 2013-10-02 12:07:46 EDT
From http://www.memtest.org/

    *** Enhancements in v5.01 : ***

        New Features
            Added support for up to 2 TB of RAM on X64 CPUs
            Added experimental SMT support up to 32 cores (Press F2 to enable at startup)
            Added complete detection for memory controllers
            Added Motherboard Manufacturer & Model reporting
            Added CPU temperature reporting
            Added enhanced Fail Safe Mode (Press F1 at startup)
            Added support for Intel "Sandy Bridge-E" CPUs
            Added support for Intel "Ivy Bridge" CPUs
            Added preliminary support for Intel "Haswell" CPUs (Core 4th Gen)
            Added preliminary support for Intel "Haswell-ULT" CPUs
            Added support for AMD "Kabini" (K16) CPUs
            Added support for AMD "Bulldozer" CPUs
            Added support for AMD "Trinity" CPUs
            Added support for AMD E-/C-/G-/Z- "Bobcat" CPUs
            Added support for Intel Atom "Pineview" CPUs
            Added support for Intel Atom "Cedar Trail" CPUs
            Added SPD detection on most AMD Chipsets
        Bug Fixes
            Enforced Coreboot support
            Optimized run time for faster memory error detection
            Rewriten lots of memory timings detection cod
            Corrected bugs, bugs and more bugs (some could remain)
Comment 1 Jaroslav Škarvada 2013-10-08 11:30:26 EDT
It's crashing on my machines. I need more time to investigate.
Comment 2 Jaroslav Škarvada 2013-10-09 12:00:30 EDT
(In reply to Jaroslav Škarvada from comment #1)
> It's crashing on my machines. I need more time to investigate.

It seems to crash if compiled with gcc-4.7.2 or newer. It works if compiled with gcc-4.4.7. Upstream ticket:

http://forum.canardpc.com/threads/83443-Memtest86-V5.01-crashes-with-gcc-4.7.2-or-later
Comment 3 Jaroslav Škarvada 2013-12-06 09:20:27 EST
I will continue tracking this in bug 1013110.

*** This bug has been marked as a duplicate of bug 1013110 ***

Note You need to log in before you can comment on or make changes to this bug.